Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Administrator
Joined
·
46,101 Posts
Discussion Starter #1

·
Registered
Joined
·
30,126 Posts
Looks the same as the standard SW but yes, ours has the holed blocked up. Velocemitch may help you on this one :D

Cheers,
 

·
Administrator
Joined
·
46,101 Posts
Discussion Starter #3
So does that mean the spoiler is (shock, horror) purely cosmetic? I thought Alfa were above that. They'll be fitting fake brake cooling ducts in the side skirts next...
Or does it still have an aerodynamic effect of some sort?
Does the (clutching at straws) air being forced to flow through just each end of it give the car more lateral stability? :D
 

·
Registered
Joined
·
17,177 Posts
Mine was blocked up too Bazza.
;)
Don't get me started on those brake ducts...
:D
 

·
Administrator
Joined
·
46,101 Posts
Discussion Starter #5
It's blocked up with a flexible rubber flap though. I wonder if, at a high enough speed, the air pressure is enough to fold that back and let air through?
Seems a strange design otherwise.

The mention of ducts was specifically to tempt you into this thread Rick ;)
 

·
Registered
Joined
·
17,177 Posts
I think the rubber is a fairly solid bung rather than a flap. I wonder if it's a dodgy moulding underneath and it covers it up?
:cheese:
 

·
Registered
Joined
·
30,126 Posts
Bazza. Washed the wifes SW this morning and her's is exactly the same as yours, not as I previously stated.

Cheers,
 

·
Premium Member
Joined
·
5,467 Posts
Mine's the same as well.... I thought about "modifying" it so that air can go through it, but I am not sure if this actually serves a purpose.

While on the tailgate subject, my rear screen washer take ages before pumping any water through it.... anyone else have this problem ?
 

·
Administrator
Joined
·
46,101 Posts
Discussion Starter #9
Mine's the same as well.... I thought about "modifying" it so that air can go through it, but I am not sure if this actually serves a purpose.

While on the tailgate subject, my rear screen washer take ages before pumping any water through it.... anyone else have this problem ?
I don't have this problem on my SW Eric, but I had exactly the same problem on the rear washer on my Coupe.
I would guess that your non-return valve is broken. I would further guess that the non-return valve is underneath the scuttle below the windscreen. You can get a replacement from pretty much any motor factor.
 
1 - 9 of 9 Posts
Top