Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi ALL

I have a 156 sportwagon. y reg. the gear box or should i say gear number 3, will not go in, i can use all other gears but not 3rd. where the gearstick is under the leather sleeve, there is a gold bar on the right hand side of it that moves slightly when moving the gear change. Number 1. is the gear box gone? 2. is the bar supposed to move. 3 . it has been suggested not by a professional that the it may have come off its track??? number 4. can anyone offer any good news on this, or is it just gonna cost a fortune that i aint got? thanks for your advise upfront. SI:cheese::rolleyes:
 
L

·
Guest
Joined
·
0 Posts
try disconnecting the 2 cables, out at the gear box, to see if the problem is at the gear stick. If the gearstick is able to move in all direction when the cbale sare disconnected then the issue is gearbox related. removal would be required
 

·
Registered
Joined
·
28 Posts
Hi ALL

I have a 156 sportwagon. y reg. the gear box or should i say gear number 3, will not go in, i can use all other gears but not 3rd. where the gearstick is under the leather sleeve, there is a gold bar on the right hand side of it that moves slightly when moving the gear change. Number 1. is the gear box gone? 2. is the bar supposed to move. 3 . it has been suggested not by a professional that the it may have come off its track??? number 4. can anyone offer any good news on this, or is it just gonna cost a fortune that i aint got? thanks for your advise upfront. SI:cheese::rolleyes:
The 'gold bar' should fit into a little rubber grommet on the white plastic housing? If the grommet wears and falls out, it lets the gear linkage flop around rather than returning under spring load to the centre position and you can see the gold bar flopping around loosely in the housing. If this has happened, it might allow you to select some of the gears and not all of them. Try wiggling it around. it should hopefully select all the gears.

Fixing it is a matter of dropping the exhaust and the sheilding above it to get access to the shift cables and mechanism. A PITB. But not as costly as a gearbox at least.....
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
The 'gold bar' should fit into a little rubber grommet on the white plastic housing? If the grommet wears and falls out, it lets the gear linkage flop around rather than returning under spring load to the centre position and you can see the gold bar flopping around loosely in the housing. If this has happened, it might allow you to select some of the gears and not all of them. Try wiggling it around. it should hopefully select all the gears.

Fixing it is a matter of dropping the exhaust and the sheilding above it to get access to the shift cables and mechanism. A PITB. But not as costly as a gearbox at least.....
Hiya thanks for that, have you pictures or how to guide on this as i am no mechanic. i have not even got the alfa manual (repair) to even look these things up. Im still having issue after issue with this alfa. i have done loads on it and more keeps coming , i am hoping that it isnt the gear box as thats me done, no car. Listen to me moan.... sorry... any more advise would be helpful.
thanks again in advance
 
1 - 5 of 5 Posts
Top