Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
When car starts from cold the idling surges. When its warmed up it often stalls usually when I come to a halt. Sometimes even going around corners in 3rd or 2nd it will stall. Had a "crank sensor " fitted recently. also a new cam belt , variator and drive belt fitted recently and had clutch solenoid replaced. It had a new MAF fitted about 3000km ago. Mechanic says "the readings for the O2 sensor are out and maybe the MAF is the problem" car is 1999 has only done 80,000kms.. I'm reluctant spend more on a new MAF if its not going to fix the problem. Any good ideas?
 

·
Registered
Joined
·
30,081 Posts
When the crank sensor was replaced, did the old "O" ring come out?
 

·
Registered
Joined
·
9,204 Posts
It will be too far away from the flywheel and not register correctly.
 

·
Registered
Joined
·
30,081 Posts
I have no idea. I would have to ask. What are the consequences if it didnt?
The sensor will be too far away from the wheel and the engine will cutout...

Check the basics though, especially look for any leaks in the air intake between the MAF sensor and the engine.
An open valve in the crankcase breather after the throttle will cause low-rev/idle issues too.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Thanks. Its going back next week and I will ask the garage to check these issues. I have read previously on here that you can clean the MAF unit, but Alfa knowledgeable mechanics I have talked to seem to think this doesnt work. Any comments?
 

·
Registered
Joined
·
10 Posts
Did you find out the problem with the low idling I have exactly the same problem. Could be the clutch or battery even???
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Mine got worse each time it went back to the garage. Last time it started surging from 1000 to 2500 on idle. Eventually we replaced the throttle body and there was a vast improvement. Still not perfect but you can live with it. The clutch solenoid had been replaced as had the battery.
 
1 - 10 of 10 Posts
Top