Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,581 Posts
Discussion Starter #1
To fix or not to fix 156 sele TS

First is the slight crunch from 2nd to 3rd gear since the gearbox was re calibrated. Is it a calibration issue? Does the clutch need replacing as the car has done 78,000 ish. Or is it the dreaded synchro s meaning lots of money.

Second is a wierd brakes issue. The pedal went to the floor and braking was very poor. Slowly got it home and thought to pump the pedal a few times and they came back to life. No leaks under the car and reservoir is on max. Is it the master cylinder finished?

Opinions would be gratefully received.
 

·
Registered
Joined
·
2,613 Posts
Firstly bleed the brakes.

For the g/box what calibration was done? You should check clutch rod length, clutch bite point calibration, and maybe do the clutch bleed routine. Assume the clutch and gearbox work perfectly apart from crunching into 3rd?
 

·
Registered
Joined
·
565 Posts
RE: Crunch.

Mine was crunching going into 2nd from either 3rd or 1st, It turned out to be contaminated gearbox oil (Selespeed oil is leaking into the gearbox). i changed the gearbox oil, and the crunch has gone.
 

·
Registered
Joined
·
1,581 Posts
Discussion Starter #4
The gearbox is working perfectly other than 2nd to 3rd.
kam325i How or where was sele oil leaking into the gearbox?

Sorry to sound stupid, I'm not very mechanically minded with these problems.
 

·
Registered
Joined
·
565 Posts
I Believe that the selespeed oil is seeping past one of the seals circled in the picture and making its way down the selector shaft into the gearbox. Although i am 90% certain its the seals on the back plate, where the up/down ram is.
 

Attachments

·
Registered
Joined
·
2,613 Posts
There's an easy check for that one - if you remove the gearbox filler plug and half a litre of oil pours out, you can be fairly certain that the actuator seals KAM325i is talking about have failed.
 
1 - 7 of 7 Posts
Top