Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hello everyone,

I just purchases my first Alfa last week end :)

156 sportwagon 1.8 2001, so far been great, my only concern is that when I am in traffic the temp gauge go up to 90 within few minutes, is that normal for an Alfa ?

Thanks for your help
 

·
Registered
Joined
·
930 Posts
It should go to 90 fairy quickly.. and stay around there.. it usually hovers between 80 and 90... How fast exactly does it climb to 90?
 

·
Registered
Joined
·
30,074 Posts
Sitting at 90 is normal, dropping below that on the move indicates that you need a new thermostat.
How low does it drop?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
THanks for your replies,

It goes from mid 50's to 90 in about 2-3 minutes.

when driving along always stay at mid 50's only go to 90 when in traffic .

is the thermostat quiet easy to change or it is one of those fiddly job that required monkey arms

thanks
 

·
Registered
Joined
·
21 Posts
Discussion Starter #10
thanks,

order the part, looking forward for a fun week end. Still have to find out where it all goes

thanks guys
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
hiya,

fitted the thermostat, pretty easy job.

Now, i let the car run for few minutes, temp gauge goes up nicely within few minutes , but doesn't stop at 90, it just keep on going.....

one thing i have done, only realised after, when i added some coolant, i forgot to mix with water. Is that could be the reason ?
thanks
 

·
Registered
Joined
·
30,074 Posts
fitted the thermostat, pretty easy job.

Now, i let the car run for few minutes, temp gauge goes up nicely within few minutes , but doesn't stop at 90, it just keep on going.....

one thing i have done, only realised after, when i added some coolant, i forgot to mix with water. Is that could be the reason ?
thanks
How hot did it get?
Any signs of the fan starting?
What condition is your rad in?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
i stop the car when it reach the next mark after 90, didn't hear the fan kick in.

should i keep the coolant cap open while the car on idle for a bit ?

haven't been for a drive yet.
 

·
Registered
Joined
·
30,074 Posts
Have you got a test meter?
If you do, check the resistor module on the fan housing next to the top hose.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #16
just to let you know,

did let the car idle again, gauge more settle at 90 ish, went for a quick drive, gauge drop slowly mid 80's.

look more like it now :)

thanks
 
1 - 16 of 16 Posts
Top