Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
My recently purchased 156 is leaking into o/s/f footwell. Following advice on the forum, I've done the following :

1) Checked the plenum chamber (unable to fully remove scuttle panel trim, 'cos the corner screws were rounded). There was some debris under there which I scraped out, but not as much as has been reported on this forum. I ran water along the panel and water seemed to drian quite quickly underneath the car, so the drain tube appears ok

2) Removed door panel to check membrane and that is water tight, and no signs of water staining on on door card. Put duct tape along membrane just in case :rolleyes:

The water in the footwell doesn't smell of anti freeze, so that should dismiss the heater matrix. Also, the aircon isn't used much so don't think it could be the aircon drain tube

Any help would be much appreciated

BTW, what's the purpose of the foam blocks in either corner of the bonnet shuts? The one on the n/s seems mashed up. Should it be changed?
 

·
Registered
Joined
·
2,904 Posts
Have you had a new windscreen recently? We had a problem with another car, which didn't manifest itself until around a year after the screen was fitted, check the front of the headlining and leading edges of the a-pillars for any dampness or staining
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
Have you had a new windscreen recently? We had a problem with another car, which didn't manifest itself until around a year after the screen was fitted, check the front of the headlining and leading edges of the a-pillars for any dampness or staining
Only recently bought the car, so can't say if screen has been renewed recently, although it's deffo been renewed in the past

Under the dash (by pedal box) seems all dry. Can't see any dampness by 'A' pillar.

It's a mystery:rant::rant::rant:
 
1 - 3 of 3 Posts
Top