Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi all,

I don't have a good feeling about this but figured I might aswell post a question.
The variator is totally finished and I have the constant dieselsound. Besides that I have something very
similar like this:

https://www.youtube.com/watch?v=ItA-by93M3U

Maybe not as loud but comes and goes at certain rpm's and also seems to depend on different engine loads.

So, what do you think?

Regards
Marcus
 

·
Registered
Joined
·
8 Posts
If the variator has been changed then it's a possible big end bearings....Hopefully you caught it in time. Time to pull the CAT, and sump off to inspect.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Hi Ronantu,

The variator is not replaced but is ordered along with all the other parts required for a cambelt replacement.
I have experienced bad variators before but not one that makes this kind of noise. Is it even remotely possible that it is the variator making this?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
So, I finally pulled the engine and found that cyl 3 and 4 bearings has spun. However, the crank looks good in both positions. Can't really feel any scoring. Nr 1 and 2 had some wear on the shells.

First time for me inspecting a crank thats been subjected to failing bearings. Is it a definite case for the machine-shop? Measure and regrind?

Also, the crank pulley bolt, is it left-handed? Loosens clockwise?
 
1 - 4 of 4 Posts
Top