Alfa Romeo Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
My 156 is giving me the runaround…
Has had odd MSCF errors - seemed to be transient fault on coil 4 (P0354)
Then it threw fatal coil failure P0301 on cylinder 1, along with P300 (Generic misfire) & P0430 (Cat 2) - I assume the latter two make sense with a coil failure.

To check it really was the coil (and not wiring or spark plug) I swapped coil 1 & 2. I also swapped plugs 1 & 3. Cleared errors with FES - still running on 3 cylinders but fault now moved to cylinder 2. Looks like the coil?
New coil fitted - but gave code P0352 - coil primary. Swap coils 1 & 2 - error moves with the coil (now P0351) OK, maybe got a duff one. Back to Europarts, got a replacement. Exactly the same. Could be a whole batch of duff ones? Or maybe Haas coils are rubbish (anyone with specific experience - I know Bosch might be safest bet, but would another make be that bad from the word go?).
There is clearly something with the coil - otherwise the fault wouldn't move with it. Am I missing anything? Is the coil just slightly different and as it's not what ECU is expecting, so throws a fault? Is there any information on the resistances should be pin to pin on the coil?
Thanks
Neil
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Replacement Bosch coil fixed it - after TWO faulty Haas coils, I would steer clear. Could be a faulty batch, but shouldn't leave the factory of they're not right.
 
1 - 5 of 5 Posts
Top