Alfa Romeo Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
2,519 Posts
Discussion Starter #1
I'm in the process (been taking my sweet time) of fitting the Xenon headlights I purchased a long while back. Started making the wiring loom to convert my existing h7 wires and to hook it up to the manual height adjust. Had a thought though. If the parts are not too expensive, it would be good to get them on the auto adjust.

The favour I need is for the one of you to follow the wiring from the self level sensors and see where they connect to at the headlight end. If up on garage ramp at the time, photos would be great!

Cheers in advance.
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #3
OEM 156 GTA Xenon headlights.

Still got to buy the sensors and wiring (below) IF it is as simple as plugging it in.
 

Attachments

·
Registered
Joined
·
30,241 Posts
I can't see it being that simple, especially on a pre-2002 156.
 

·
Registered
Joined
·
1,823 Posts
how / where were you able to source the headlamps?

not to sure where to look, but more than happy for you to come and look at mine if it helps?
 

·
Registered
Joined
·
272 Posts
Let us know how you get on; would be a nice upgrade. My lights are ok, but a little pitted on the glass. I too am curious where you got the parts from and how much... I am Jan 2003 model, so I suspect the install will be a little different.
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #7
how / where were you able to source the headlamps?

not to sure where to look, but more than happy for you to come and look at mine if it helps?
Got the first one (passenger) two years ago off eBay. Guy never sold it so I emailed and offerred £50 and picked it up from Southend.

Second one took another year, £40 ish again from ebay. A week later, found another drivers side so got that for spares.

Pig nose connector from eBay Italy.

Will defo take you up on the offer when the weather is a tad milder :)

Cheers.
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #8
Let us know how you get on; would be a nice upgrade. My lights are ok, but a little pitted on the glass. I too am curious where you got the parts from and how much... I am Jan 2003 model, so I suspect the install will be a little different.

Refurb your lenses. Pascs or Redd on here put up a HOW TO.

Once done, get some Lamin-X clear film to protect it as the UV lacquer would have gone.
 

·
Registered
Joined
·
272 Posts
Nice one, I did not know you could refurb then lens, the results look excellent. Cheers, I will give that go in the summer, deffo :)
 

·
Registered
Joined
·
143 Posts
Hi Rob3rto!

I got some pictures of the sensors in a car fitted with them!
It's what I'll use to do in mine.

If you wan I'll post them for you.

I don't understand what you mean with "... see where they connect to at the headlight end."

Cheers!
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #11
Cheers, that would be great. What I meant was does the wiring from the sensors connect to the plug for the headlight or does it go somewhere else first.
 

·
Registered
Joined
·
143 Posts
Rob3rto, the wires from the sensors go only to the connectors on the headlights.

Here are the pictures of the front sensor:









The rear sensor:










Alfa didn't sell the bracket for the rear sensor, but it does now.
But it is diferent from the one in the car in the pictures. Also the metal "S" thingy is also different.

When I get home I'll take some pictures and post the, here so you can see.

I bought all the bits from Alfa (still waiting for the sensor plugs) anda the cost for everything was about 360€, because they did a discount...
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #13
So what you are saying is that it is "Plug n Play"?

Excellent. Just what I thought :) Thanks. Post More pics as and when you get them.

360€ is a lot though. Suppose i'll have to pay it. I did get the lights for £100 :lol:
 

·
Registered
Joined
·
143 Posts
Lucky! :D

I'm just waiting for the connecors and cables for the sensors, I have everything else.

Since the 156 doesn't use CAN it is fairly simple to get it working, but after everything is in place it will be necessary to go to the dealers and calibrate the sensors and headlights to its "zero" position.

Will take pictures at the parts later today.
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #15
Argh! Was hoping to avoid a trip to the stealers. No other way to calibrate?
 

·
Registered
Joined
·
143 Posts
I don't know of a program that can do that except the examiner or fiatdiag, so a trip to Alfa will be necessary...

Here are some pictures of the parts:

Front parts (still missing one bracket):





Rear parts:





Difference between front and rear sensor (it's only the lever):



Difference between the two metal links:



Pins for connectors:



Connectors:



And Headlights:



I'm also missing the two sensor connectos and cables.

By the way, why is
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #17
Thanks. What are part numbers for the bits you are missing? Can't find any reference on ePER.
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #18
By the way, why is code off when I try to reply?[/QUOTE]

You have to upload them to Alfaowner using the paperclip symbol above.

No idea where the image link went.
 

·
Registered
Joined
·
143 Posts
The part numbers are:

60682704 for the bracket
60679193 x 2 for the cables

In the pictures you posted above these two pieces are there.

You can use the parts from a 147 or GT with OEM xenon, because they share the same parts.

Might be easier to find used parts from those models instead of the 156's...
 

·
Registered
Joined
·
2,519 Posts
Discussion Starter #20
OK. So how do they hook up to the headlight connectors?
 
1 - 20 of 38 Posts
Top