Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I've recently bought an early 03 159 2.4 JTD.

In the last week or so my fuel economy has dropped from an average of 50mpg to 30mpg.
Running consumption figures show a drop of approximately 50% from previous.

Can anyone give me an idea of where to start?
Performance doesn't seem to be affected at all.

Thanks guys.
 

·
Registered
Joined
·
257 Posts
May be a daft question but have you taken into account that the fuel prices have gone up too as of last week, suprisingly, many people fail to factor that in....
Since it's a JTD the first point of call is the EGR valve, is it closing properly.... As Ianfm has suggested it could be thermostat related... The temp sensor gives the info to the ECU and in turn the ECU tells the EGR to close. ... There is always a cause to a problem, so find the cause first.....Hope it helps m8
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
The temperature takes a while to climb to about 80, but no longer than when I bought it.
Have recently changed oil, oil filter and air filter.

Ronny_V6 - I'm referring to the onboard display data, both average and real-time.
How do I check operation of the EGR, and where do I find it?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
The EGR seems okay - solenoid moves freely.
Top hose gets hot after 20 min motorway run, so *assume* thermostat is not the issue (temp characteristics unchanged from before problem anyway).

Any pointers to tests / checks would be appreciated.
 
M

·
Guest
Joined
·
0 Posts
Do you get alot of smoke when you accelerate hard and have you noticed a performance loss in the car
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Haven't noticed any smoke yet, tho if accelerating hard I'm generally looking forward.
Performance - I feel it could be better, but not sure about any drop.

I started it from cold yesterday and let it idle - took 15 min to raise the needle just past 50deg, top hose still cold at 20min.
 

·
Registered
Joined
·
257 Posts
Haven't noticed any smoke yet, tho if accelerating hard I'm generally looking forward.
Performance - I feel it could be better, but not sure about any drop.

I started it from cold yesterday and let it idle - took 15 min to raise the needle just past 50deg, top hose still cold at 20min.
Hmmm. Now we have to start looking at the basics.

When was the last time the fuel filter was changed and also the air filter?
Both can have a detrimental affect on diesel fuel economy if they are dirty. Try not to take for granted that just because the service isn't quiet due, that they will be clean... even a slightly soggy air filter due to running through a puddle for example can attract dirt like there is no tommorow!.... So it's advisable to check physically m8.
Does the engine tick over steadily once it is warmed up or do the revs drop periodically? A sign that the MAF or the throttlebody could be a little dirty.
Check the induction pipes for any splits in the mean time too
Let us know how you go m8:thumbs:
 
M

·
Guest
Joined
·
0 Posts
Sounds like a sticking thermostat if you let it warm up fully and drive it on an open road and see if it drops back down to the start it is knackered..
 

·
Registered
Joined
·
12,881 Posts
I started it from cold yesterday and let it idle - took 15 min to raise the needle just past 50deg, top hose still cold at 20min.

I have to be honest diesels don't produce hardly any heat when idling ( my dial will also not really move when sitting on my drive), however once the engine is under load it should get up to temp relatively quickly, mine gets up to 88 in about 4-5 minutes ...


(oh and I changed my stat last year and my radiator is still in good condition)
 
1 - 11 of 11 Posts
Top