Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have replaced all the front suspension on my 156 Selespeed apart from the front anti-roll bar and it is much improved apart from slightly vague straightline steering. Would worn anti-roll bar bushes cause this?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Yes i had the front and rear alignment carried out,the only thing i can think of thats making the steering wander is the anti-roll bar or prehaps the rack has play in it, which i hav'nt checked yet
 

·
Registered
Joined
·
2,519 Posts
Dodgy rear treiling arm to lower hub bushes can cause this as it allows the rear wheels to move backwards and forwards.

Did you change all the wishbones up fron ttoo or only the shocks/dampers?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I've got new Konis, springs,top and bottom wishbones, link rods and Powerlex bushes on the top wishbones and new track rods. The rear has had new Koni shocks, springs, Powerflex bushes in the tie bars and rear hubs. Can only think the anti-roll bar bushes or wear in the rack is causing the vague straightline wander.
 

·
Registered
Joined
·
3,013 Posts
Did you fit lowered springs? the geometry could now be different, also althought the tracking has been done, it may be worth getting it re tracked, I have had cars done, and they weren't done quite right, a check just to be sure wouldn't hurt.
Also what about the tyres/pressures?
How much did the powerflex bushes cost?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
I had matching lowering springs with the shocks. I check the tyre pressures often but i will get the tracking checked again. The Powerflex bushes were bought from Demon Tweeks, i can't remember the cost but they were expensive!
 
1 - 7 of 7 Posts
Top