Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I was letting my car idle to defrost it, was running fine, but then cut out after 5 mins and would not restart. I was low on fuel and just assumed that it had run out. I got a can full of petrol but it made no difference. The car will start and run for about 3 seconds, but will cut out after that or will cut out if I put my foot on the accelerator.
I have changed the crankshaft sensor, but it made no difference.
Any suggestions would be welcome :)
 

·
Registered
Joined
·
44 Posts
If you think it may of run out of fuel, id put another can of fuel in it as lots of cars wont start now unless at least two gallons of fuel are in the tank. The fact it starts and runs for a couple of seconds discounts the crank sensor to me. Good luck!
 
D

·
Guest
Joined
·
0 Posts
I was letting my car idle to defrost it, was running fine, but then cut out after 5 mins and would not restart. I was low on fuel and just assumed that it had run out. I got a can full of petrol but it made no difference. The car will start and run for about 3 seconds, but will cut out after that or will cut out if I put my foot on the accelerator.
I have changed the crankshaft sensor, but it made no difference.
Any suggestions would be welcome :)
Why did you change the crankshaft sensor ?
Did it come up when you had error codes read ?
I do agree that if you are low on fuel two cans will most likely be neede before it starts
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Okay off to get some more fuel, will let you know!!.
Changed the sensor on the advice of some 'well meaning, ill advised expert' lol, was not the most pleasant of jobs in the cold and wet, and my arms feel it this morning :(
Just wish I'd gone on here earlier!!
 
D

·
Guest
Joined
·
0 Posts
Well to be fair the crank sensor problem is well known but its not the only thing thta would stop car from starting.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Cheers guys. Just put another can of fuel in and started first time, it is now defrosting, and then off to the garage to get a tank full, never to run out again!!
Hopefully no need to post again this week, so happy xmas everyone :)
 
D

·
Guest
Joined
·
0 Posts
Cheers guys. Just put another can of fuel in and started first time, it is now defrosting, and then off to the garage to get a tank full, never to run out again!!
Hopefully no need to post again this week, so happy xmas everyone :)
Good news !!

These cheap "fixes" are great :lol:
 
1 - 8 of 8 Posts
Top