Alfa Romeo Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hello, alfaowners!
I know there are many threads dealing with the same subject, but i did not find any resolve to my problem..

So, my 2,0 156, has some serious laziness in it..

I have already changed MAF, and lambda, i also changed the intake pipe from MAF to throttle body, as the old one seemed to be ripped.
No changes to the cars behaviour..

Its like, i dont have ANY power under 2900rpm, then it starts going better, but still there isnt all of the power from factory, maybe 120hp :rolleyes:

It goes normally with half a throttle, but when the pedal is in the floor, it doesnt make any difference compared to half a throttle.. The car idles well, when on hot engine the idling may sometimes be a little high.

Maybe it misses a tooth on timing?

Timing belt is changed about 10000 km`s ago, and after the change it worked really well.
We did rebuild the whole engine again, as we bought the car as engine faulted.

I tried to spray some starter pilot to the intake parts, to see if it leaks air on somewhere, but didnt find any leaks.
Is there some tests that i can do without diagnosis programs? I have read the fault codes, but there wasnt any codes suggested to the problem, excepting the code from the lambda, i checked the parameters and the lambda was dead on there.. So i changed it after that, now its good on parameters too!

All the help would be appreciated! :)
 

·
Registered
Joined
·
30,421 Posts
Have you tried it under full load with the MAF sensor unplugged?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Yes i have, now.
So i unplugged the maf, there where no changes after that.
Idling went rough for a couple of seconds and the injection light came on, but still, it was lazy.

Should it affect much, if the MAF is in working order, or broken?

Ive tried 3 MAF:s but, there where no changes. I dont believe that all of them could be broken.
Any other ideas?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Could be the variator. Is there someway that i can test that it is the variator? Heard that it is quite an expensive thingy to change..
It does make the "diesel" sound at warm start...
How should the car work if i unplug the variator solenoid, if the solenoid works?
 

·
Registered
Joined
·
5,227 Posts
Variator wouldn't cause erratic idle.
Can cause flats spots yes. But that is all.

You are not expecting it to pull like a diesel are you? Because half throttle and wide open throttle there isn't much difference in power - Petrols need rev's to get them to go.
 

·
Registered
Joined
·
974 Posts
When were the plugs last changed?

Baz
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
No, i dont expect a diesel like torque.. But i think that there isnt all the horsepower, especially on the low rpm`s. Im never driven another 2,0 T.Spark, so i can not compare them though.
I changed the four big spark plugs about 10.000km ago, dont remember when the little ones have been changed.
Thank you for the answers, i will read the fault codes when i get the reader, and see whats in there again..
 

·
Registered
Joined
·
30,421 Posts
I changed the four big spark plugs about 10.000km ago, dont remember when the little ones have been changed.
All eight sparkplugs should be changed at the same time.

What plugs did you use?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #11 ·
Yeah i know, but the little ones looked okay so i didnt change them. :lol:
The main reason for changing the big ones was that i broke one of the old ones during the new engine installation, so i changed em all.

I bought spark plugs made by Bosch. I think that they are original ones from factory and should do their job..

Will change the little ones soon..
 

·
Registered
Joined
·
30,421 Posts
I bought spark plugs made by Bosch. I think that they are original ones from factory and should do their job..
Nope.

Plugs were:
4x NGK BKR6EKPA
and
4x NGK PMR7A
 

·
Registered
Joined
·
30,421 Posts
You can think what you like, but you've asked about your engine being slow, you've put different spec sparkplugs in and only replaced half of them.

Your issues may not be due to sparkplugs, but it isn't a great start to sorting out issues...

You say you've also replaced the MAF & Lambda sensors..... did you use lower cost alternatives for those too...?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #15 ·
They are not different spec.
The old spark plugs were all made by BOSCH, the small ones too. Thats why i bought the same kind of Bosch spark plugs to replace them..
Lambda and MAF, they are both made by Bosch, so they are genuine too, not the cheap copies that are sold in the ebay..
The Bosch spark plugs wasnt even cheaper than the NGK ones, here in finland.. So no lower cost alternatives used.
 

·
Registered
Joined
·
30,421 Posts
They are not different spec.
The old spark plugs were all made by BOSCH, the small ones too.
The old ones may have been, but the original plugs would have been the NGK I mentioned above.
 

·
Registered
Joined
·
974 Posts
David, Bosch UR6DE & FR7DC+ are direct Bosch replacements for the NGK ones. Am currently using them myself, as the NGK ones weren't available at the time, & "Ruby" is running as good as ever.

HOWEVER, I would recommend to ALWAYS use what the Owners Manual says to whenever possible.


I agree with you completely that the small ones SHOULD be replaced to start with here, as all the symptoms he is describing are IDENTICAL to the problems I suffered when my 156s plugs were on their way out.

Baz
 

·
Registered
Joined
·
2,042 Posts
I can't believe that the little plugs are at fault here.
I've run mine with the little leads disconnected and it makes VERY little difference.
Have any of the codes been read?
Air filter clean? Disconnect it temporarily and try again. Don't forget to put it back on!
Air leak? Check those inlet hoses.
Ecu reset?
I'd say check the fuel filter but I don't think it has one?
 

·
Registered
Joined
·
5,227 Posts
I'm with Egon. I don't think the sparks would cause irregular idle.
 
1 - 20 of 22 Posts
Top