Alfa Romeo Forum banner

1 - 6 of 6 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Afternoon all,

So about 3 months ago I had the clutch done on the car under warranty :D (71K)

Time has passed, children have been born etc.

The clutch pedal for the past month + has been doing rather wierd things.

Slightly notchy, really heavy or nice and light and easy to use.

Could this be the??

Clutch and / or Flywheel ?

Master Cylinder?

or

Slave Cylinder?

Thanks all :thumbs:
 

·
Registered
Joined
·
78 Posts
Hi, any idea somebody?
I have the same issue with my 156(same engine), clutch was done 1 week ago and since then doing this.
The mechanic sprayed some grease to the top of the pedal and stoped but 3 days later did it again, so now I have the grease spray in the boot and keep spraying it, but this solve the problem just temporary...
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Wahooo not just me then.

I heard some where that if a new clutch is fitted, it can blow the seals in the master cylinder?

TRUE? who knows?
 

·
Registered
Joined
·
1,928 Posts
you are going to have to pour a heck of a lot of oil down the shaft to get it into the bottom bush as there is a big flat stop just above it and oil will have to some how overcome this.....i recon itll drip of it and be nowhere near the bush

when a new clutch is fitted a mechanic should clean and grease the bottom bush and the top one and the fork the release bearing fits on..........my clutch is very light and very smooth as i did all this when i changed my clutch
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #6 (Edited)
Since posting the damn pedal is super light...................... :lol:

Shall have to monitor why it does it, Ambient temp, city driving, long journeys etc etc..

Cheers all
 
1 - 6 of 6 Posts
Top