Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey all :)

Sorry if this has been covered before I looked and couldn't find it.

Have an 03 plate 1.9 JTD, only had a couple of months and love it, it's my first alfa and does have some faults with front brakes and suspension which I'm going to be working on.

Had occasional slipping of clutch and grinding when trying to engage gears and a loud clunk when put clutch down a couple of weeks back, occasional slip and grind etc but nothing else for 8 days and probably best part of 500 miles, now it gets confusing.....

Parked up fine last Tuesday after doing probably 75 miles that day, got in Wednesday morning to head to work put in gear and had no biting point at all :(, engine running can go through gears without moving clutch pedal at all, my mate had a look (mechanic of 18years) could hear it driving in 5th gear and diagnosed faulty clutch...

Had clutch out (plate seems ok probably half it's wear left) so new kit is in place although having problems getting box to engage with release bearing so still on stands at the moment but starting to wonder if could be something more serious after reading around forums, what's most worrying is when car supposedly in gear it can be pushed around and can turn drive shafts by hand :confused:

Could anyone shed any light on this please
 

·
Registered
Joined
·
9,516 Posts
If the clutch is OK, the only other real possibility is that the final drive has failed - you can check this while the box is out by rotating the input shaft and checking if both outputs rotate.....for the offside output you'll need to fit something into the inner output cog....
 

·
Registered
Joined
·
2,652 Posts
If it was the final drive I don't think you'd be able to change gears with engine running without using the clutch, but still worth checking. More likely a failed gearbox input shaft, assuming the clutch and flywheel are ok. Have you held the clutch driven plate and hit the centre with a hammer to see if it falls out?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hey, thanks for the replies turned out it must have been pressure plate causing the issue, it was stuck further in than it should of been so must of weirdly reversed itself and acted as though clutch was always engaged, it drives fine now all replaced n slave cylinder rebled although could be an underlying issue with the slave cylinder so that's on shopping list.
Once fractured power steering pipes fixed I can enjoy driving him again :)
 
1 - 4 of 4 Posts
Top