Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Totally fed up I have a beautiful car sitting on my drive and just can't get it to run properly no 3 cylinder had a diagnostic and its says number 3 cylinder then gives me option new plugs coil pack injector compression or wiring well done two plugs and coil going to find a local garage to do a combustion test hope its not that can't afford to rebuild engine.... I have noticed a few 1.8 losing compression at just over 100000 miles is this normal?
 

·
Registered
Joined
·
180 Posts
Head Gasket?

I had a similar problem with a non-Alfa recently ..... all it did was misfire- poor compression in cylinder #2. My local garage didn't want to touch it with a bargepole, so I took it to an Italian specialist ... who diagnosed a blown Head Gasket!!
 

·
Registered
Joined
·
1,374 Posts
Get a compression test and leak down test. I have a 1.8ts 16y old 95k on clock and runs like a train. The 1.8 TS is supposed to be the most robust.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Getting compression test Tuesday if it fails I will scrap it and get another one I love the style probably a diesel.
 

·
Registered
Joined
·
1,374 Posts
Getting compression test Tuesday if it fails I will scrap it and get another one I love the style probably a diesel.
I still love my 156, despite buying a 3.2 GT. Driving the 156 atm as the 3.2 is having a top end rebuild. Am so reluctant to sell the 156 as at 16y old and 94k I won't get much for her. We've been through so much together!
 
1 - 5 of 5 Posts
Top