Alfa Romeo Forum banner

1 - 4 of 4 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hi

I have a 155 Q4 with a climate control problem, or rather the internal fan is intermittent in it's operation. Some days it'll work fine, other days it won't come on at all. I can stop the car, turn it back on, and hey presto, the fan is working again; any ideas?

Any ideas?

Regards
 

·
Registered
Joined
·
61 Posts
G18LLO said:
Hi

I have a 155 Q4 with a climate control problem, or rather the internal fan is intermittent in it's operation. Some days it'll work fine, other days it won't come on at all. I can stop the car, turn it back on, and hey presto, the fan is working again; any ideas?

Any ideas?

Regards
Is it making any noises like a squeeky noise? If so suggest u take the fan off, lubricate it and adjust the blower(the black plastic thing connected to the motor) push it down a bit coz it will most likely b out of place with all the years of it being used, and this is what causes the noise coz of catching against the fan cover. But if urs isnt making a noise im not 2 sure :tut: , but check if ur cooling fan stops workin 2 if ur heater fan stops, then it cud be some fuses/relays, if not then its some loose wires somewhere but have no idea where :confused: Gud luck wit it :)
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Sounds like the thermal resistor next to the fan..in the passenger footwell....or possibly the control unit...will search for the diagnostic webpage...ang on.

Bad news is for a climate control equipped car they aren't cheap!

wrinx
 
1 - 4 of 4 Posts
Top