Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi

Just dismantled the battery shelf etc to get at the MAF filter to give it a clean as the MCSF code indicated poor air quality. It seems that an air leak might be happening as it appears there are two bolts missing that would connect the hose section where the MAF is to the airbox.

There seems little point putting it all back together without solving this problem anyone know how the sizes so I can go and try and buy some?

Nick

Short term would taping the round the section help if I do put it all back together?

Nick
 

·
Registered
Joined
·
30,243 Posts
Are they missing, or snapped?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
missing - there is a hole for a bolt on the housing with the MAF sensor in it and then what looks like a metal nut molded into the air filter housing. I assume they have shaken loose over the past 95000 miles. Or were removed by a previous owner and never refitted... or never there in the first place?
 

·
Registered
Joined
·
30,243 Posts
If they are just missing, you are lucky.
Most in your situation find they are snapped..!

They are listed as: M6x12mm
When you fit them, coat the threads with Copaslip and then do the same with the heads after fitting.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Have done as suggested. I assume this will probably turn out to be the likely source of the air leak which was one of the possible issues that led me to be getting reayd to clean the MAF

I will find out over the ext few days of the MCSF light goes off... expecting it to take 6 -8 ignition cycles.
 
1 - 5 of 5 Posts
Top