Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
ive had an alfa 147 for the past month and a half now and have just noticed that when going over bumps and rough ground the back of the car sounds a bit clunky and sometimes squeaky. does anyone know why this may be? or what maybe causing this?

im not the most knowlegable on the mechanics yet.


by the way its a 56 reg 1.6l twin spark, lusso.

thanks
 

·
Registered
Joined
·
405 Posts
mine does this too. i thought it was the boot so wound the rubbers as far out as possible ensuring the boot still closes without having to slam the hell out it but its still the same. im thinking it might be something in the spare wheel well???
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
thanks alfa-****, i will try takin everthing out of the spare wheel well and go for a drive but it sounds a lttle more serious than that. but i will give that a try anyway.
thanks
 

·
Registered
Joined
·
3 Posts
Back noises

Had the same problem , and it was ....front suspension. Upper and lover wishbone plus anti roll bar (around 350 with labour to change). If by the chance it's only rear suspension it might be rear track control arm(s) (around 100 pound for 2 plus 30-50 for fitting)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
bielson thanks, doesnt sound very good to me that but at least its an answer, i will need to have a garage look at it
 

·
Registered
Joined
·
405 Posts
put some silicone spray on my boot rubbers today and it seems a bit better. i used to get the same sort of squeek noise from both sides but now only slightly from one side. worth a try mate.
 
1 - 7 of 7 Posts
Top