Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Everyone,

Just bought a great looking 147 (1.6...03...light blue (693 met) lusso with 35k).

As seems to be the norm.., it looks fantastic, drives fantastic, is fantastic, and i'm currently 'ironing out the usual niggles.'

Cambelt and all tensions etc- done!
Odo flashing (peroxy(?) alignment)-done!
3/4th gear linkage into gearbox free'd off-done!
light in boot-Done!

The only thing left is the usual 'fuel mixture' bringing the ECU management light on..

I'm just locating a maf sensor (£195+vat genuine part) but the Bosch part No. doesn't seem to match the usual 147 advert references.. It's Bosch 0280 218 113..

Anyone had the same problem or has a Bosch cross-reference etc..?

Cheers

Keelman :thumbs:
 

·
Registered
Joined
·
656 Posts
Hi Everyone,

Just bought a great looking 147 (1.6...03...light blue (693 met) lusso with 35k).

As seems to be the norm.., it looks fantastic, drives fantastic, is fantastic, and i'm currently 'ironing out the usual niggles.'

Cambelt and all tensions etc- done!
Odo flashing (peroxy(?) alignment)-done!
3/4th gear linkage into gearbox free'd off-done!
light in boot-Done!

The only thing left is the usual 'fuel mixture' bringing the ECU management light on..

I'm just locating a maf sensor (£195+vat genuine part) but the Bosch part No. doesn't seem to match the usual 147 advert references.. It's Bosch 0280 218 113..

Anyone had the same problem or has a Bosch cross-reference etc..?

Cheers

Keelman :thumbs:
£195 + vat Thats expensive i'm sure you can pickup a genuine bosch for half that price
 
1 - 3 of 3 Posts
Top