Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have been having trouble with my engine for past 5/6 months, the dealer changed all the tappets and the variator under warranty in November 2006, but I was still not happy as engine was still noisy, so took it back 2 weeks ago, January 2007. Got phone call last week saying they were putting a new engine in under warranty which runs out this March!!!! I am definitley not complaining, but can't believe the trouble I have had. Apparently when they took the head off they found a blocked pipe which meant my engine was getting no oil and has serverely damaged the engine beyond repair!!!
Anyone else having problems!!!
 

·
Registered
Joined
·
1,807 Posts
Guess that's what warranties are for. Welcome and hope it's even better when all repaired.
 

·
Registered
Joined
·
1,807 Posts
Guess that's what warranties are for. Welcome and hope it's even better when all repaired.
 
N

·
Guest
Joined
·
0 Posts
Wow!

Close call with the warranty!

But hopefully it'll be good as new soon.

Welcome BTW!
:)
 

·
Registered
Joined
·
666 Posts
Got the variator done under warranty recently, then the tappets got noisy as hell. They're being done tomorrow. My warranty is up start of February, great timing.
 

·
Registered
Joined
·
1,807 Posts
Sounds fractionally suspect PMackay, going by the many threads mentioninig oil levels hereabouts.
 

·
Registered
Joined
·
16,710 Posts
Well, if the pipe was blocked your dealer did the right thing. Let hope you have no more problems :)
 
1 - 8 of 8 Posts
Top