Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
419 Posts
Discussion Starter · #1 ·
few issues ive been having lately with my car
most annoying one is that the radio seems to have reset the preset stations and wont allow me to tune anything else, so basically stuck to only listening to cds.

any solutions to this problem? can i reset the radio?
 

·
Registered
Joined
·
10,929 Posts
Do you have the radio code? You can disconnect the battery and leave it disconnected for 10 mins but will need the radio code to get it to work again.
 

·
Registered
Joined
·
419 Posts
Discussion Starter · #6 ·
hahaha @alfigt thats what ive been doing, no mp3 means a lotta cds to haul

so ive tried disconnection the radio to no avail. have fm1 (all 6 presets stuck on 99.2) fm2 on 96.4 and fmt on 94.7. cannot fine tune and autotune doesnt pick up anything.( is my radio on the way out???)

2nd issue i have is a stuttering/loss of power when car is cold, seems like the car forgets its on low gear and struggles to get power and then just kicks back. Jzee said it could be coilpacks.

3rd issue annoying rear break squeak and occasional rattle(rear pads are new ferodo)

any help greatly appreaciated.
 

·
Registered
Joined
·
4,740 Posts
Thanks Arthur greatly appreciated. Will try that today.
If they the platinum series, get used to it, no amount of bedding helps with the squeal...
You have to warm the breaks up with one good "stop" before they stop during each trip, works for all my clients that use it
 

·
Registered
Joined
·
10,929 Posts
Use the handbrake to stop a couple of times. Don't just pull it up and hope for the best or your rear wnd coukd overtake your front end...
 

·
Registered
Joined
·
2,694 Posts
If they the platinum series, get used to it, no amount of bedding helps with the squeal...
You have to warm the breaks up with one good "stop" before they stop during each trip, works for all my clients that use it
Does a liberal coating of copperslip not help this?
 
1 - 11 of 11 Posts
Top