Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter #1
Rattle knocking from the car, thought it may be suspension but can't see or feel any issues.

Sounds like front drop link issues, but when they have gone in the past I could see where they had failed when investigating. I've been under the car and everything is tight as....

No lateral movement in the ARB either.

All trims, exhaust and heat shields seem to be OK.

Am I missing something? :confused:
 

·
Registered
Joined
·
5,227 Posts
Check the top wishbone hasn't worked a little loose!
 

·
Registered
Joined
·
337 Posts
Discussion Starter #3
Seems solids and no movement their either (bother when jacked up and on the road). It did work loose when I fitted it. Will double check tonight (with a spanner this time).
 

·
Read Only
Joined
·
4,556 Posts
It is incredibly hard to spot the rattling component, even if you get underneath with a prybar.

Simple example. I poly'd the upper arms and replaced the drop links on my 156. 2 weeks later it was clattering. I lift her up, and take a pry bar to everything, including the ARB. No problem. I noticed that the undertray was a bit loose, so refixed that and test drove. Still rattled. So I lifted it again, and went over every nut that I had undone - and one of the ARB drop link nuts was a fraction too loose. Nipped it up half a turn, and all was silent.

Droplinks are disposable service items - almost every other year for me.
 

·
Registered
Joined
·
337 Posts
Discussion Starter #5
Awesome. Drop links changed. No knocking. Good call.

Top tip: - had a git of a time with one of the lower bolts, ended up having to cut it off. Cleaned the other one (dremel with wire brush) and greased it before loosening. Came off in a jiffy without tearing my hands apart (unlike the other one). :cool:
 
1 - 5 of 5 Posts
Top