Alfa Romeo Forum banner

1 - 15 of 15 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
The car in question is an 147 05 1.9jtd

Inserting the key nothing happens, no lights on the dash appart from the air bag icon bottom right of the speedo, i turn the key that light goes out but nothing happens the car doesnt turn over.
Ive put a meter on the battery and im fetching 4vs so there's a battery drain somewhere and i have no idea where to start.
I had to attach a battery charger and with that attached all the lights on the dash illuminate like a chistmas tree and i get a faint immobilliser fault on the dash but if a turn the key everything goes out and there's a clicking behind the fuse box which obviously in the body computer ..
The lights, indicators radio .. nothing is working

So with that what would you do ..

**Shoot me now icon **
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #3 (Edited)
I have mate Yes and Ive checked all the fuses in each fuse box ..
Ive been reading where a blown bulb might cause battery drain but why wont it start ? Inserting the key and turn it on id of at least thought id have lights on the dash or indicators or headlights , even the central locking doesnt work


Edit, Since the last reply ive put another battery on it and a rely is clicking in the fuse box infront of the battery, but still no lights on the dash or engine turnover when i turn the key ..
 

·
Registered
Joined
·
9,559 Posts
I suspect I've answered this on FB - but have you checked your earths....?
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #6
I don't believe this, the clutch has gone now, the peddle is hard to press and its dropped, Christ I don't need this now
 

·
Premium Member
Joined
·
7,680 Posts
...Inserting the key nothing happens, no lights on the dash appart from the air bag icon bottom right of the speedo, i turn the key that light goes out but nothing happens the car doesnt turn over.
Ive put a meter on the battery and im fetching 4vs so there's a battery drain somewhere and i have no idea where to start.
I had to attach a battery charger and with that attached all the lights on the dash illuminate like a chistmas tree and i get a faint immobilliser fault on the dash but if a turn the key everything goes out and there's a clicking behind the fuse box which obviously in the body computer ..
The lights, indicators radio .. nothing is working

So with that what would you do ..

**Shoot me now icon **
Sounds like a bad battery. If you read 4volts, the battery is definately dead !
Attaching a battery charger will not help you start, the power drain of the starter motor is way too much for a normal charger to supply, with a dead battery.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Sounds like a bad battery. If you read 4volts, the battery is definately dead !
Attaching a battery charger will not help you start, the power drain of the starter motor is way too much for a normal charger to supply, with a dead battery.
But ive put a better fully charged Newish battery on and now i get all those lights where as the older battery at the start of the thread i got no dash lights as i say ..
I've changed the starter motor and when i turn the key everything goes dead as you can see in the video ..
Could it be bcm ?
 

·
Premium Member
Joined
·
7,680 Posts
...I've changed the starter motor and when i turn the key everything goes dead as you can see in the video ..
Could it be bcm ?
It would seem to point to a short circuit during starting.....
Is the start relay ok ? If you hadn't replaced the starter motor, I would suspect that. However, as you changed it, I assume it's ok.
Can you turn the motor over, ie is nothing seized ?
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #11
It would seem to point to a short circuit during starting.....
Is the start relay ok ? If you hadn't replaced the starter motor, I would suspect that. However, as you changed it, I assume it's ok.
Can you turn the motor over, ie is nothing seized ?
As soon as you turn the key to start the engine everything goes dead.


When i insert the key i get all the dash lights on and the clicking, but sometimes, As well as all the dash lights/clicking the indicator or headlights wont work but if i remove the key and then reinsert i'll get all the dash lights/clicking but then everything ( headlights, indicators, radio ect ect ) will work ..

No nothing is siezed ...
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Which is the starter relay , I take it its in the engine bay fuse box infront of the battery ?
 

·
Registered
Joined
·
2,271 Posts
Would the clicking sound not be the solenoid for the starter disengaging as their is insufficient current?
Try jump leads from another running car. If I've read the thread correctly the condition of the second battery has not been confirmed.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #14
A proper charge and its as good as gold, now for changing the clutch ...
 
1 - 15 of 15 Posts
Top