Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
Was out and about in Bella Lusso's 1.6 TS 147 the other day and the gear selection can only be described as random. The gearstick will self centre, but going from second to third, or vice versa is a random experience. The only way I can describe it is as if the gear selector linkage is worn or the gear gates are loose........:confused:

Could any one help with some advice or direct me to posts that may have covered this issue?

thanks:thumbs:
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
Cheers for that Dave, but assuming I am a novice.......what is it exactly, the gate selector assembly?
 

·
Registered
Joined
·
74 Posts
Discussion Starter #4
hmm, nice to see the friendly helpful forum members here have offered their help and advice:confused:

as before......any help would be greatly appreciated:(
 

·
Registered
Joined
·
143 Posts
I had the same problem sounds like the linkage buddy, it gets sticky/worn over time and a build up of swarf can make selection of 3rd gear difficult (common on 147's i believe), you just need to wip it off and give it a clean up or stick in to a garage to do it for you shouldn't take much longer than 15/20 mins
 
0

·
Guest
Joined
·
0 Posts
"hmm, nice to see the friendly helpful forum members here have offered their help and advice" <--- that's gonna encourage others to spend time helping aint it? ;)

Who is Dave?? :confused:

Have you been under the car & checked for the component (or similar) I highlighted & checked the bushes?
 
1 - 6 of 6 Posts
Top