Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hoping someone can help. Have a 2004 147 selespeed, always leave in neutral when not used. Has an intermittent issue which if not used for a while when started and select 1st gear , 2 shows on the display but the car is actually in reverse , if you try and select reverse then the car goes into neutral. Only way I've found to get to reset is by turning off a d restarting the car a number of times..... seems to take a lot longer doing this process if car been sat for a while.

Have scanned and no fault codes, and can hear the prime up procedure every time drivers door us opened , selespeed oil is also topped up.

Any help would be appreciated.
 

·
Registered
Joined
·
120 Posts
Hi nzsmithers

Welcome to the Forum.

Whereabouts in NZ are you? I am in Christchurch and we have a man in the Alfa Romeo Owners Club (AROC) that might be able to help you.
 

·
Registered
Joined
·
13 Posts
I just thought I'd ressurect this. I have seen this. generally it is the gear position sensor getting out of alignment/tolerance. If you re-run the end of line calibration, it will fix the issue, and reset the position sensor to the mid point of the gear position at rest, and allow for the normal tolerance. With age I have to do this once or twice a year these days. With multiecuscan it only takes 5 mins..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I just thought I'd ressurect this. I have seen this. generally it is the gear position sensor getting out of alignment/tolerance. If you re-run the end of line calibration, it will fix the issue, and reset the position sensor to the mid point of the gear position at rest, and allow for the normal tolerance. With age I have to do this once or twice a year these days. With multiecuscan it only takes 5 mins..
Thanks so much Pasey25, thats a massive help 👍👍👍
 

·
Registered
Joined
·
13 Posts
you're welcome. Interestingly, I have been told on a number of occasions to leave it in gear when at rest. as soon as the key is turned, the clutch engages and selects neutral anyway.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
you're welcome. Interestingly, I have been told on a number of occasions to leave it in gear when at rest. as soon as the key is turned, the clutch engages and selects neutral anyway.
Ive been told the opposite , to take out of gear...... couple of times i forgot i seem to have the issue . Who knows 😁
 
1 - 8 of 8 Posts
Top