Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
Just wondered if anyone can help me. When I was out driving the other day, I pulled up at a junction that was basically a very sharp left turn and then an immediate sharp right turn, there was a low pitched drone from the front end that could only be described as a similar noise to a faulty wheel bearing, it has done it a couple of times since but always at low speed and when on near full lock.

I have checked the power steering fluid and also the gear oil level, both are perfect also the gear oil is only a few months old as it had a Q2 fitted at Auto Lusso.

So any Ideas :confused: :thumbs:
 

·
Registered
Joined
·
685 Posts
My "guess" would be a noise part and parcel of the power steering or is it perhaps just the Q2 working??

:confused:

Good luck :thumbs:
 

·
Registered
Joined
·
89 Posts
Discussion Starter #3
My "guess" would be a noise part and parcel of the power steering or is it perhaps just the Q2 working??

:confused:

Good luck :thumbs:
It doesn't always do it and it hasn't done it since last week. I'm just back in just now from driving it and was on full lock in a carpark driving at low speed and it was quiet no noises at all.

The Q2 shouldn't really make any noises though should it? This was a distinct low pithced drone like a wheel bearing.
 

·
Registered
Joined
·
25,673 Posts
It's the Q2, don't worry about it. ;) Mine sometimes does it as well on full lock, not sure why but I quite like it, makes it feel more mechanical :thumbs:
 

·
Registered
Joined
·
3,801 Posts
Powersteering on a few of my cars have made a droning noise on full lock, this 156 probably more than others. If the powersteering fluids topped up, I wouldnt worry too much.
 
M

·
Guest
Joined
·
0 Posts
Mine too. Not convinced it should do this - it didn't right after the diff had been fitted but took a little time to manifest itself.

Seems to me if it wasn't noisy but now is after a thousand miles or so, then something is not right. I'm keeping an eye on it, well an ear actually.
 

·
Registered
Joined
·
89 Posts
Discussion Starter #10
Mine too. Not convinced it should do this - it didn't right after the diff had been fitted but took a little time to manifest itself.

Seems to me if it wasn't noisy but now is after a thousand miles or so, then something is not right. I'm keeping an eye on it, well an ear actually.
Exactly My thoughts....
 

·
Registered
Joined
·
238 Posts
I have the same "drone" when turning on hard lock, its quite loud now!

it was checked over by Autolusso, diagnosed as PAS pump, had a used one fitted but still the same....
 

·
Registered
Joined
·
89 Posts
Discussion Starter #13
I have the same "drone" when turning on hard lock, its quite loud now!

it was checked over by Autolusso, diagnosed as PAS pump, had a used one fitted but still the same....
I hate it when garages mis-diagnose a problem, charge you a fortune to sort it and all you end up with is a light pocket.. :tut:
 

·
Registered
Joined
·
5,551 Posts
Check under your car for a bent/crushed power stering pipe. I had a bent one that gave these exact symptoms and was £25 for the elbow. It lives inbetween the gearbox and the radiator (undertray has to be off). Well worth a good look.
 

·
Registered
Joined
·
238 Posts
I hate it when garages mis-diagnose a problem, charge you a fortune to sort it and all you end up with is a light pocket.. :tut:
yeah but it was my decision to give it the go ahead. The price was fine for the part and the labour. Just disappointed that it didnt solve it! Who knows, a brand new one might have cured it....but couldnt justify the £400+ price tag!
 
1 - 15 of 15 Posts
Top