Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have recently swapped my 33 for a 147. A couple of times - infrequently - when I've been slowing, the warning panel has flashed up with ABS and VDC failure messages. Obviously this is something I should worry about, but how much? I turn the car off and back on and it's all reset and fine. Any advice?
 

·
Registered
Joined
·
1,436 Posts
Get a alfadiag on the car to check the exact error codes. That'll tell you that is really happening.
 

·
Registered
Joined
·
7,027 Posts
This sounds very much like a faulty brake light switch, a common problem- the fact that it happens when you're slowing, i.e. braking, tends to confirm that. If so, diagnostics are a waste of time as it doesn't set an error code. The good news is that a new switch is cheap & very easy to replace.
 

·
Registered
Joined
·
953 Posts
This sounds very much like a faulty brake light switch, a common problem- the fact that it happens when you're slowing, i.e. braking, tends to confirm that. If so, diagnostics are a waste of time as it doesn't set an error code. The good news is that a new switch is cheap & very easy to replace.
Agreed, I have replaced my brake light switch just 4 days ago due to this very problem - the part cost me £12.43 inc VAT and to 2 minutes to fit with no tools required. It did reduce the problem but not totally cured it - it turned out that my battery was shagged so I threw in a Varta Silver Dynamic and now my bella is cushty - have had an ABS warning since.
 

·
Registered
Joined
·
1,752 Posts
The latest AlfaDiag does cover some ABS ECU but you will need a modified cable as I think that the ABS ECU uses a different pin to the Engine and Airbag ECUs
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks very much everyone. So far it's only happened a couple of times, when slowing and in both cases it was in the morning, ie, first drive of the day. I'll keep my fingers crossed that it doesn't happen again otherwise try the brake light switch ... at which point I'll need some help on how to change this. Thanks again.
 

·
Registered
Joined
·
568 Posts
I have recently swapped my 33 for a 147. A couple of times - infrequently - when I've been slowing, the warning panel has flashed up with ABS and VDC failure messages. Obviously this is something I should worry about, but how much? I turn the car off and back on and it's all reset and fine. Any advice?


It could be your battery is on the way out, but check that the brake lights come on when you press the pedal.

The latest alfadiag does support the 147s ABS as long as it has the Bosch 5.7.
 
1 - 10 of 10 Posts
Top