Alfa Romeo Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi,

I'm a first time Alfa owner - one week and counting - and have already run into problems!

Bought a 2001 147 1.6 TS Lusso from a dealer near my parents - I live 200 miles away. Driving it home that night, the engine control system failure light came on after 120 miles - so rang the dealer the next day, and arranged to drop it off the following week to get it sorted - they told me it was probably a faulty warning light.

Picked it up yesterday (08/03), no warning light, they told me problem was fixed. Drove back to parents' and took it out today - guess what, the light came on again, less than 24 hours after picking it up.

Dad's had a few Alfas before, so knew they can be temperamental, and he'd ordered me a diagnostic reader thingy the first time the light came on. Plugged it in when I got home, and it's given me codes P1177 and P1178. Research on your lovely forum shows this is probably a MAF problem (?) - and I can get stuff to clean it, which would be the cheapest and easiest way to solve it.

I'm just not sure if

a) we're right about what the problem is
and b) whether I should ring dealer and get them to fix it as their responsibility - I've had this car about ten days and they provided a comprehensive 12 month warranty. When I picked it up yesterday, the guy was quite dismissive and just said "oh, it's an Alfa, lights just tend to come on..."!

Don't want to keep driving around with the Engine Control System light on, and not sure what to do. Any advice would be appreciated.

Many thanks :)
 

·
Registered
Joined
·
25 Posts
Hi Library Girl. Firstly welcome to the joys of Alfa ownership. There are a few threads on here showing how to clean a MAF, it maybe a simple job of cleaning it. However, if I was in your position I would give the car back to the garage and ask them to fix it - properly. If the MAF is playing up then get them to clean it out, then if it fails again, get it replaced - that's what a warranty's for!!! Good luck and keep us posted!
 

·
Registered
Joined
·
9,912 Posts
Hi,

I'm a first time Alfa owner - one week and counting - and have already run into problems!

Bought a 2001 147 1.6 TS Lusso from a dealer near my parents - I live 200 miles away. Driving it home that night, the engine control system failure light came on after 120 miles - so rang the dealer the next day, and arranged to drop it off the following week to get it sorted - they told me it was probably a faulty warning light.

Picked it up yesterday (08/03), no warning light, they told me problem was fixed. Drove back to parents' and took it out today - guess what, the light came on again, less than 24 hours after picking it up.

Dad's had a few Alfas before, so knew they can be temperamental, and he'd ordered me a diagnostic reader thingy the first time the light came on. Plugged it in when I got home, and it's given me codes P1177 and P1178. Research on your lovely forum shows this is probably a MAF problem (?) - and I can get stuff to clean it, which would be the cheapest and easiest way to solve it.

I'm just not sure if

a) we're right about what the problem is
and b) whether I should ring dealer and get them to fix it as their responsibility - I've had this car about ten days and they provided a comprehensive 12 month warranty. When I picked it up yesterday, the guy was quite dismissive and just said "oh, it's an Alfa, lights just tend to come on..."!

Don't want to keep driving around with the Engine Control System light on, and not sure what to do. Any advice would be appreciated.

Many thanks :)
lights come on because there is a fault ,it seems to me they have just erased it and not fixed it ,so notify this dealer that either they sort it or youll put it into an alfa specialist or dealer for them to fix and they pick the bill up ,yes it is their responsibility ,
 

·
Registered
Joined
·
9,912 Posts
Hi Library Girl. Firstly welcome to the joys of Alfa ownership. There are a few threads on here showing how to clean a MAF, it maybe a simple job of cleaning it. However, if I was in your position I would give the car back to the garage and ask them to fix it - properly. If the MAF is playing up then get them to clean it out, then if it fails again, get it replaced - that's what a warranty's for!!! Good luck and keep us posted!
I wouldn't do that :rolleyes:
I would first of all ,take the flexi pipe off inlet and check its not split or got leaks first
you can end up destroying a perfectly working maf sensor ...you only do this as a last resort before purchasing a new one
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks everyone, backs up what my dad said, so going to ring the dealer in the morning. Possibly going to ring AlfaAid first to confirm what the codes are...
 

·
Registered
Joined
·
2,263 Posts
I wouldn't do that :rolleyes:
I would first of all ,take the flexi pipe off inlet and check its not split or got leaks first
you can end up destroying a perfectly working maf sensor ...you only do this as a last resort before purchasing a new one
Pretty much this.
Don't even try to clean the MAF, most of the time you'll end up killing it. If you do insist on giving it a try only use isopropyl alcohol, most other things will leave a residue and cause inaccurate readings of both flow and air temp.
 

·
Registered
Joined
·
450 Posts
lights come on because there is a fault ,it seems to me they have just erased it and not fixed it ,so notify this dealer that either they sort it or youll put it into an alfa specialist or dealer for them to fix and they pick the bill up ,yes it is their responsibility ,
Exactly what Dave says! :thumbs:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 ·
Thanks everyone - reset the error codes on Monday, took it for a drive, light came back on. Reset again, went for a drive with Dad so he could judge performance, and sod's law... didn't come on until we took it out at 10pm! Dropped it off with dealer this morning, and he gave me the "lights just come on" line again - this time extending it to Audis as well. Told him I want the problem fixed, not just the error resetting, so hopefully he knows I'm aware that's a possibility and will actually do something. Fingers crossed... :(
 

·
Registered
Joined
·
9,912 Posts
No doubt your speaking to salesman.its eating into his bonus .if they cant fix problem you should notify them that they should take it to someone who does ...I hope they supply you eith a replacement car whilst they scratching their back sides ...
 
1 - 11 of 11 Posts
Top