Alfa Romeo Forum banner

41 - 60 of 118 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #41
Great, the one I'm possible picking up on Thursday is at 50k, lol. Guess I'll be looking at getting that sorted sooner rather than later.

Is there anyway tell tail signs that I may notice when test driving or do they just fail.

Cheers for the heads up.
 

·
Registered
Joined
·
3,919 Posts
2 of mine broke off at about 60,000mls. I've seen comment from Autolusso that they've seen them fail by 30k, or still be OK by 120k+, but there's a bell curve that puts most failures between 70-100k. It's a 'do you feel lucky punk' proposition.
Exactly, they deffo need to be done, all I was saying was that its not 100% certain that they will break but they should be done to be on the safe side.

Great, the one I'm possible picking up on Thursday is at 50k, lol. Guess I'll be looking at getting that sorted sooner rather than later.

Is there anyway tell tail signs that I may notice when test driving or do they just fail.

Cheers for the heads up.
You wont get very far on the test drive if they have failed !
 

·
Premium Member
Joined
·
391 Posts
I already said about the little oil filter probably being the cause.

Thanks for info, New pipes fitted with new turbo n 147. Don’t know if they removed the filter? Spent today replacing clutch slave cylinder on 147( that was a pain to remove almost fused to holder) failed suddenly with nice leak yesterday.

Back to Turbo,s question?

I wonder if my 159 2.4 has the same sort of filter in turbo pipe. Is it fairly easy to remove banjo bolts thinking as a preventative on this?

cheers
P
 

·
Registered
Joined
·
3,919 Posts
Not sure if the 2.4 has the same, its a different turbo, but there will be a filter somewhere, not heard anyone say its a problem on the 2.4.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #45
Evening guys,

Has anyone had issues with their air con on the 147? Autolusso have picked up that the car I'm possible getting has an air con leak near the bulk head.

Is this common and does any know if its an expensive fix?

Cheers
 

·
Registered
Joined
·
3,919 Posts
Its common, couldnt tell you about the price though. Its so common I d expect it on any 147, 156 or GT.
 

·
Registered
Joined
·
1,947 Posts
The long pipe can rub against the bulkhead/inner wing if the insulation gets displaced. I think new ones are about £150, but add awkward fitting and £90-ish recharge. Don't be surprised if the condenser is knackered, which was the problem on mine (pipe ok) at 10yrs old, and doing that I discovered the radiator was on its way out as well.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #51
Evening guys,

Can anyone help I've just bought myself a 147 Ducati Corse and I've come across a problem on my drive home. On a couple of occasions whilst driving all the warning lights came on on the dash plus the speedo and fuel gauge dropped to zero. There was no loss of power nor was there any flickering on the heads lights. The lights, gauge and speedo all reset them selves and all was fine. It now happened 4 times in the last 24hr hours or 500 miles.

Any advise would be appreciated.

Dean.
 

·
Premium Member
Joined
·
45,238 Posts
Check all ECUs for stored fault codes. Check battery voltage, stationary and engine off, engine running, engine running with all electrics switched on. Check battery terminals are tight, check all earths are clean and making good contact.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #54
Cheers Pud237,

I'll have a look tomorrow and see if I can spot anything obvious then go from there.

Cheers
 

·
Premium Member
Joined
·
45,238 Posts
Did you see the black one in west Yorkshire just before Christmas for £1200? I was tempted by that one myself.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #56
Typos1

I went for the Black one with 50k, the engine is solid and pulls like a train (even more so now I had it remapped in my way home) needs a good deep clean. It's a little rough around the edges but once I've sorted a few things I think it will look good. A little disappointed in the standard stereo it sounds pants guess I'll just add that to the list lol. It was handy coming with 2 sets of wheels as 2 of the originals have buckles in them, looking to getting that sorted tomorrow. Its also in dier need of an under seal, swirl flap delete etc etc. Lol
Still I'm happy and ready to get stuck in.
Does anyone nlknow the best place to get a skid plate from that's missing as well. :ROFLMAO:
 

·
Registered
Joined
·
3,919 Posts
Dunno I swapped my written off 147 for a clutch/Q2 fitted to my new 147 and the Bose kit years back, but you can get the whole kit for about £150 on ebay, pretty easy to fit too.

Found this one :


You could make him an offer (you dont need the headunit its the same for Bose and non Bose versions).

Or Pud237 (Autolusso Penrith) may have some in stock . . .
 
41 - 60 of 118 Posts
Top