Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter #1
Hi all,

I'm just after having a new battery fitted, now the key fob only intermittently works, sometimes after working there is a delay and either the indicators flash again and usually the windows desend slightly or all the way.

If I only turn the key in central locking, sometimes the windows go down, even though not pressing any keyfob buttons etc.

I'm guessing some sort of eletrical fault after battery has been fitted - can someone advise if it best to just start pulling all fuses to see if any blown or if there is something more specific I can be doing?

Cheers
 

·
Registered
Joined
·
3,806 Posts
Try removing the battery and refitting. You may also have co-incidentally disturbed the key and made a problem that was waiting to happen, happen! It sounds like you have switch sticking on, a broken switch or a crack in a solder joint. Either way it sounds like the keys needs sorting out.
I fix keys for a living but I'm not touting for trade, just telling you what I think your problem is.
Leave this key inside and use the spare one and if everything is ok then you know it's the key for sure.
Kind regards
Chris
 

·
Registered
Joined
·
184 Posts
Discussion Starter #3
thanks for reply :thumbs:

YEah, in meantime I've come to same conclusion as was standin g by car and coudl see the alarm constantly being disengaged, so the 'off' key is sticking on. I took out teh battery and hey presto.

I had removed the fuses for window control units to prevent the windows from lowering until I figured this out. seems obvious now...

This is my 'new' key as the old key alarm functions starting to not function well/reliably however the key is still good.

What would you charge for a refurb on the newer key(PS I'm based in Dublin) - presumably the key woudl not need to be retuned to alarm freq etc, you can just clean up the circuit board contact etc yeah?

Cheers!
 
1 - 3 of 3 Posts
Top