Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
368 Posts
Discussion Starter #1
Hi Guys

Sorry to raise this old chestnut again, but I've searched the forum, read a good few replies and have ended up confused :confused:

Accelerated out of a junction this afternoon and gave it some welly for a hundred yards or so :tut: :D when I noticed that the red airbag light had come on :rolleyes: . I'm assuming the wiring under the seat has moved and caused the indication but what I need to know is:

If I mess around with the connectors (reconnect them, check them, whatever) and by some miracle accidentally make the contact again, do I need to get the warning reset by a dealer, or will it reset itself or do I reset the ecu? (presumably by disconnecting the battery for 30 mins) (Its a '02 2L TS btw).

There definitely seems to be some disagreement/difference of opinion over this so can anyone clarify ...please?.....pretty please with a cherry on the top etc?:eek: C'mon please don't make me beg like this :p ;)
 

·
AO Car Of The Year Winner 2015
Joined
·
3,202 Posts
From what I have read on this forum, even if the cause of the light is cancelled (you reconnect the connector or whatever) it has to be reseted by the dealer on examiner.

From my experience, my airbag light doest fit this behavior, as few times it light up, was on for a few kilometers and then went off and back on after some time. Sometimes it went on and off 3-5 times in 10km, sometimes it was on for 500 km and than went off. Since my last reset by the dealer (more than 1 year) it didn’t light up.
 
1 - 2 of 2 Posts
Top