Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hi all, wondered if anyone could point me in right direction??

I have hooked alfa diag to my ecu via a modded cable (cable from Rarebear - very good btw), and found 2 fault codes, one of which was the passenger airbag on/off switch for baby. I have cleared this one using a new switch. I still have one fault left. It is code 0005 and the text shown in AD is as follows:

Failed Component Code: Passenger AirBag Inhibition Light
Error Code Status: Intermittent Fault Present
Error Type: Open Circuit
Static Image Of Lifetime Timer in Snapshot: 108785 Minutes

Now this leads me to the actual light in the dash (which is still on!). I dont know where to start with this one to be honest, and dont want to take the whole dash apart unless it is absolutely necessary!! Anyone had this fault and manged to rectify, or anyone who knows how I can sort it?? Please help!
 

·
AO Car Of The Year Winner 2015
Joined
·
3,202 Posts
Isn’t that just the typical connector issue on passenger seat? “Open circuit” on passenger airbag seems to be it. Get under the seat, reconnect the connector, erase the error message and see. If you have heated seats, there are two connectors under the seat, yellow is the airbag, the other seat heating. It might just need to unplug and plug back. Many users have cut the connector and soldered the wires, the fault is so often. I wrapped it in tape so that it can’t be unplugged by vibrations.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Maybe relating to pass seat - i dont know, although prior to getting AD and the cable and after searching on here, I had already hardwired both passenger and driver underseat connectors in the hope of the faults clearing themselves - which they obviously didnt! I just thought that Light would mean the actual dashlight?? (even tho it is always on and doesnt flash!?)

Incidently, heated seats dont work either, fuse ok.......
 

·
AO Car Of The Year Winner 2015
Joined
·
3,202 Posts
Maybe relating to pass seat - i dont know, although prior to getting AD and the cable and after searching on here, I had already hardwired both passenger and driver underseat connectors in the hope of the faults clearing themselves - which they obviously didnt! I just thought that Light would mean the actual dashlight?? (even tho it is always on and doesnt flash!?)

Incidently, heated seats dont work either, fuse ok.......
The airbag light doesnt go off when you remove the fault. It always has to be cleared by computer. So the light either means you have a problem or that you had a problem which you removed, but didnt erase the error message yet.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Yes the lights dont go out by themselves, which is why i purchased AD and the cable....

I used AD to read the codes, 2 faults apparent, tried to reset, still there, fixed one and reset, one code left, tried reset, still there, the code is 0005 with the detailed text as below:

Failed Component Code: Passenger AirBag Inhibition Light
Error Code Status: Intermittent Fault Present
Error Type: Open Circuit
Static Image Of Lifetime Timer in Snapshot: 108785 Minutes
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
i hasd the same message cleared the fault and its not returned since just connection issues i think
just wondering where i should start looking, have hard wired both under seat connectors and the one behind the dash accessed by removing the glove box; the passenger switch is ok as i replaced that and it cleared one of the faults.
 
1 - 7 of 7 Posts
Top