Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Hi there,

I had an amp and sub installed about 4 months ago and all of a sudden the amp has stopped working.

I checked the fuses on the amp itself and they're still ok. The wiring goes into the back of the headunit (standard alfa headunit..cassette with multichanger) and rather than get the headunit out, I wanted to check the fuse.

However, I don't know which fuse would have been used for the external connection on the headunit...can anyone help with this at all?

M3ckon
 

·
Registered
Joined
·
989 Posts
have you tried taking the amp out and put it back in within the last 4 months?? my amp fired itself cos an idiot bassjunkie person tried to connect the power to my amp without disconnecting the battery first. small spark came out then that was end of a 200 quid amp! :mad:
 

·
Banned
Joined
·
1,895 Posts
tse_adam said:
have you tried taking the amp out and put it back in within the last 4 months?? my amp fired itself cos an idiot bassjunkie person tried to connect the power to my amp without disconnecting the battery first. small spark came out then that was end of a 200 quid amp! :mad:
Im selling all my audio equipement and the install that houses it in the boost.I will be in Santa Pod next weekend with the car if you wan buy all of it.Let me know .

300 euro(230 pounds sterling )for the lot.12 300 watt sub,4 channel Magnat 800 wat amp.the custom made and factory fit housings for it all also a custom made parcel shelf and 2 6x9 DB Audio 4 way speakers.

Basicly all the audio install that you saw in pics of my car at the modified car shows.

A polished rear upper brace and roll cage for my 147 means that all the audio stuff cannot go back into my car so Im selling it all.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #4
fixed it!

After reading here thought I'd check to see whether or not they'd powered the amp from the battery. They'd added a fuse and thankfully the fuse had blown.

Cheers for the advice anyway
 
1 - 4 of 4 Posts
Top