Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,379 Posts
Discussion Starter #1
Over the last few months my internal oil level monitor firstly dropped one bar and now, first thing in a morning shows its dropped two bars, I always do the manual check too and it does seemed to have dropped (about 1/4 of the way between min and max....

The car was serviced about 14 months ago with oil change and ive only done about 10k in it this year because of having the GT in July, is this normal usage for a car thats done 60k but now lots stop start urban work?

I had a look under the bonnet and two of the pipes coming off the turbo are looking quite oily, any ideas....:confused:
 

·
Registered
Joined
·
219 Posts
some oil comes off the head into the black plastic pipe connecting the turbo, that happens quite often also do to some diesel dilution in oil that evaporates... you can put another clamp over the first one..
try to check if some oil is coming from the turbo , could be the turbo seals, but I wouldn´t bet on that.
10k 1/4 down is not that strange if you do a lot of small trips running the car cold. would be worst if you started to have to much oil readings.
change the oil and filter it is also time to do it..
 

·
Registered
Joined
·
1,379 Posts
Discussion Starter #3
Its going to be changed next Friday but the oil service says i have another 9k to go....
 

·
Registered
Joined
·
1,637 Posts
1.9 diesels don't use a lot of oil - sometimes none - but yours seems pretty normal. Depends on many things, including how often it is redlined :)
An oil change certainly won't do it any harm
 
1 - 5 of 5 Posts
Top