Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
833 Posts
Discussion Starter #1
Having a problem with my 1.9jtd. In high gear i put my foot down and no power comes on, then after a delay the power starts to come on gradually. although primarily in high gears it does happen in others.

EGR? any ideas anyone?

This happened a few days ago, the AA thought it was the clutch. Took it to my local trusted garage they said it wan't. So i need some help please!
 

·
Registered
Joined
·
154 Posts
It doesn't sound like an EGR symptom to me - when mine failed there was almost no power until 2500 revs or so then power came in all at once. I think what had happened was the valve stuck open until 2500rpm then suddenly shut bringing all the power in at once.
Perhaps if the valve stuck nearly closed and then never fully closed it would give the symptoms you describe but it feels unlikely.
Symptoms remind me of fuel starvation.
 

·
Registered
2017 Guila 2.0 Tbi Lusso spec, 1972 S2 Spider Junior, wife drives 939 Spider, + Abarth 595
Joined
·
6,707 Posts
Having a problem with my 1.9jtd. In high gear i put my foot down and no power comes on, then after a delay the power starts to come on gradually. although primarily in high gears it does happen in others.

EGR? any ideas anyone?

This happened a few days ago, the AA thought it was the clutch. Took it to my local trusted garage they said it wan't. So i need some help please!
Most definitely sticky EGR valve, will only get worse before you find yourself at the side of the road. Please dont do that its bad for the image of the brand.
 

·
Registered
Joined
·
833 Posts
Discussion Starter #5
apparently it's the flower shutter valve? Is that the same as the EGR valve? Any dieas on cost of replacement?
 

·
Registered
Joined
·
972 Posts
Never heard of a flower shutter valve, but if it's like the EGR in that it's sooted up, rather than broken, it might be worth trying running it on one of the super fuels (BP Ultimate or Shell Vmax) or adding a big dose of Millers to the diesel to see if the cleaning agents help. That and an 'Italian tune-up' might free it up. It's just a guess (from a non-technical person) - it all depends how bad it is; but I would certainly be tempted to give it a try before spending money on a garage bill (assuming you're not covered by warranty).
 

·
Registered
Joined
·
138 Posts
I think I have the same problem. Just started a day or so ago. Curiously I have just put in a tank of high octane fuel...perhaps this is connected. It does feel like turbo lag...right up to about 2500-3000 rpm. The turbo is working ok according to the gauge but does seem to go all the way back down to 0 which I didnt think it was supposed to. Any results with your investigations anybody??? ...and cost?
Do I need to see a main dealer or any garage for a check over?
 

·
Registered
Joined
·
772 Posts
It doesn't sound like an EGR symptom to me - when mine failed there was almost no power until 2500 revs or so then power came in all at once. I think what had happened was the valve stuck open until 2500rpm then suddenly shut bringing all the power in at once.
Perhaps if the valve stuck nearly closed and then never fully closed it would give the symptoms you describe but it feels unlikely.
Symptoms remind me of fuel starvation.
I seem to have this problem with a 2.4 JTDm. No power until about 2500 rpm (when the turbo boost gauge suddenly starts moving fast). Previously the boost gauge would move after a slight accelerator press, now I get nothing until 2000 rpm. What exactly was your fix ?
 

·
Registered
Joined
·
833 Posts
Discussion Starter #10
It was the EGR valve. Cleaned but it happened again so i replaced the EGR valve, all has been fine since
 

·
Registered
Joined
·
772 Posts
It was the EGR valve. Cleaned but it happened again so i replaced the EGR valve, all has been fine since
Thanks for the update. Mine does sound more like the description by Jess Hurchist, or was your's the same too ? or just a high gear problem ?
 

·
Registered
Joined
·
3,807 Posts
no one seems to have mentioned this but your MAF could be faulty.... cheaper than an EGR anyway. Unplug it and see if it runs better, if yes then theres the fault. If the EGR was knackered or its starting to fail you would leave some nice black smoke screens behind you.
 

·
Registered
Joined
·
772 Posts
no one seems to have mentioned this but your MAF could be faulty.... cheaper than an EGR anyway. Unplug it and see if it runs better, if yes then theres the fault. If the EGR was knackered or its starting to fail you would leave some nice black smoke screens behind you.
I thought a MAF problem was more about lumpy/jerky ride ? Where is the MAF located on a 2.4, pics ?

Any chance FiatECUScan can detect any potential problem ?
 

·
Registered
Joined
·
4,241 Posts
Maf is mainly top end - low end is egr.
 

·
Registered
Joined
·
4,241 Posts
I thought a MAF problem was more about lumpy/jerky ride ? Where is the MAF located on a 2.4, pics ?

Any chance FiatECUScan can detect any potential problem ?
Maf will be on the intake after air box prob under battery tray.
 

·
Registered
Joined
·
3,807 Posts
MAF failure would be that car just isnt responsive, ive never had a jerky or lumpy ride with a faulty MAF, just when you floor it you get nothing for quite some time and then slowly the car starts to gain speed. Im not sure on the 20v as i have the 10v but on the 10v it is located where the turbo hose goes into the air filter box. Just above the box there is a plastic cone with an electrical connection to the left of it pointing towards the thermostat. careful though as more than likely your hands will be bleeding afterwards :lol: just unplug it and you will know straight away if that was the problem. FiatECUScan would definitely pick it up, i have a different OBDII connector but i guess it should be simply called MAF readout.. hope this helps. just took a look at a 20v engine bay and it seems that the MAF is in the same place as the 10v :thumbs:
 

·
Registered
Joined
·
3,807 Posts
Maf is mainly top end
depending how far gone it is... if it completely knackered then there would be no power at all, maybe has a combo of both the MAF and EGR. I know i did and the performance was dire, changed them the other day and the car now flies...
 
1 - 18 of 18 Posts
Top