Alfa Romeo Forum banner

1 - 20 of 55 Posts

·
Registered
Joined
·
338 Posts
Discussion Starter #1
Hiya peeps... my 156 developed this odd whiring noise when reving engine...

Water pump seems to be pumping water still, belts all look good, turbo hoses are seeming to in one piece, is this the clutch or thrust bearing as it sounds like it coming from the engine block itself... but is hard to locate where the sound is coming from.

Would it be the pulleys or idlers? or maybe the alternator?

Any clues would be brilliant... i dont want to drive it just in case it makes it worse...

Follow link below for video of sound... sounds like a police siren when im driving... just need some blue lights and im away...

Engine Noise - YouTube
 

·
Vendor
Joined
·
46,115 Posts
Sounds like the turbo to me, perhaps a chipped variable vane or something. I've known a few of them to do it, including one of my old 2.4 10v JTDs.
 

·
Registered
Joined
·
338 Posts
Discussion Starter #5
Right so it does sound like the turbo, i cant seem to find anywhere that sells them on the net... just looking for prices etc... any ideas?
 

·
Registered
Joined
·
59 Posts
All my turbo diesels have sounded like this from my old 1.6td audi 80, merc C250TD and my GT 1.9;)
 

·
Registered
Joined
·
1,928 Posts
before u go spending it do more research..it sounds like what i said it was but id hate u to spend money needlessly........removed the pipe from the compressor side.......right hand as u look at the turbo.......you should be able to see the impellor have a good look see if u can see anything....bit harder to see the turbine end as exhaust needs to come off.........the parts can be replaced

some people live with the noise !

Gary
 

·
Registered
Joined
·
338 Posts
Discussion Starter #9
cant seem to remove the centre hard plastic pipe from the turbo without removing a few things... i have how ever just taken off the lower turbo hose for a good look, obviously cant see very far in via that route...

But saying that a fair bit of oil ran out of the lower turbo hose when removed, does that sound right???
 

·
Registered
Joined
·
6,357 Posts
doesnt oil running out of the bottom hose mean knackered turbo oil seals?
 

·
Vendor
Joined
·
46,115 Posts
All turbos weep a bit of oil, with the 156/147/GT it all tends to collect in the lower hose & the intercooler, giving the impression of a much larger leak than the tiny amount that does actually get through the seals. I've never seen a JTD without a lower turbo hose that has oil sitting in the bottom of it.
 

·
Registered
Joined
·
338 Posts
Discussion Starter #14
All turbos weep a bit of oil, with the 156/147/GT it all tends to collect in the lower hose & the intercooler, giving the impression of a much larger leak than the tiny amount that does actually get through the seals. I've never seen a JTD without a lower turbo hose that has oil sitting in the bottom of it.
Yes it was at the intercooler end of the pipe where the oil was... if anything its added an oil change to the list... very thin and black was the oil

well ive had a bit of fun digging around under there, seeing as its a little above my knowledge its gonna get looked at tomorrow by someone who knows better.

will get the airfilter done while its been looked at, after poking about it seems a right job even to change that.

Cheers for your all your help on this, ill update this post as soon as i get a full diagnosis on the turbo.

:thumbs:
 

·
Registered
Joined
·
338 Posts
Discussion Starter #15
Also im getting this GT17VNT turbo code, for the 140bhp engine 192A5.00016v for my 156 and not the one mentioned in post 8.
 

·
Registered
Joined
·
338 Posts
Discussion Starter #16
Ok... just dropped it off at WADs in Wolverhampton... Diagnosis confirms the Turbo is shot.

They quoted around £800 for a new turbo from Alfa or £550 for a recon unit, so obviously ive gone with the recon turbo... they kindly arnt charging me £50 for the Diagnosis but in total including Vat and Labor its gonna cost £872.40.

Ouch!
 

·
Registered
Joined
·
1,928 Posts
Ouch indeed, these recon people know how to charge
Prob £100 in bit total!
If it's not burning oil then a new shaft would have been all that u needed
Would love to know wot diagnostics u need apart from your ears to tell what the problem was !!
 

·
Registered
Joined
·
338 Posts
Discussion Starter #18
Ouch indeed, these recon people know how to charge
Prob £100 in bit total!
If it's not burning oil then a new shaft would have been all that u needed
Would love to know wot diagnostics u need apart from your ears to tell what the problem was !!
Yea i even went in there and told them it was the turbo... and have Alfa diag also so hmmm... not overly impressed with "Alfa Indies" round here...

Also the 02' 147 (170,000mile) courtesy car i got off them yesterday has a golf ball bulge in the front tyre wall, it was given to me like this however i didnt notice it till i got home... called WAD this morning and they asked me to put a new budget tyre on it... at least so i can still use it... i took the car to a tyre shop today for them to point out theres another bulge in the rear tyre. also.. thats as well as the one i found in the front tyre... so its cost me two tyres. I will be getting the money back off my turbo bill thats for sure...

As for WAD giving out very old and illegal courtesy cars... well, i went to them by recommendation... not so sure ill be going back next time round. Or passing that recommendation on to anyone else in future... shame really.
 

·
Registered
Joined
·
212 Posts
well, i went to them by recommendation... not so sure ill be going back next time round. Or passing that recommendation on to anyone else in future... shame really.
I am really sorry for this outburst but this is a load of tosh!!! you've got on your profile that you're from worcestershire - if you have an issue with WAD, go to NJS in Worcester - In my opinion, they are leagues apart in terms of service - WAD being THE ABSOLUTE DOGS AND NJS BEING PANTS.

As for your comment about the courtesy car, THERE IS ABSOLUTELY NO WAY ON EARTH that I can believe that Adrian and the chaps would ask you to sort their car out on their behalf. I used them myself for a recon on my turbo - yes, they took a little longer than expected but they kept me appraised ogf the situation all the way through. They had the car in on a couple of other occasions and they sorted it out within a day and had the car back to me in tip top condition.

The ONLY indy I have found that is on a par...maybe better than WAD is AUTOLUSSO. HOWEVER, have you seen how long WAD have been going for? You don't get to have a business that has been going strong for that long by doing the things that you claim.

I really am sorry but I have to disagree with ABSOLUTELY EVERYTHING you have said - I am not saying you're a liar but you must have come to WAD for a reason - you say it's because of recommendation - so you're friend is lying bag of worms?

WAD are damned good and Adrian and the chaps know their stuff - sorry you've had a bad experience but I would like to say that they are fantastic!!!
 

·
Registered
Joined
·
338 Posts
Discussion Starter #20
You know what... i just wasted 5 mins replying to your post... but **** it... who are you anyway?

Oh hang on... you'd rather not say!

PS... for everyone else...

I have no doubt Adrien and the guys there know their stuff, they have great reviews on all the sites, just dissapointed with the car they lent me and the condition it was in. We all know how dangerous it is drive around with a bulge in our tyres.
 
1 - 20 of 55 Posts
Top