Alfa Romeo Forum banner

1 - 20 of 23 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My 1.8 16v has been running off for a while now. Had it diagnosed as the lambda sensor. Fitted a new bosch component, didn't seem to make a difference. on either the fuelling of performance. Performace was very poor, extremely flat in the mid rev range. I have put a K&N panel filter into my 1.8 16V.

I then decided to put the MAF sensor from my 2.0L 16V. I didnt cross refference the part numbers to check if they are the same but it does seem to make a difference on the performance. Although I have not verify that the MAF from the 2.0L 16v is outputting a perfect signal/reading.

I have also heard that the water temp sensor can cause the aforementioned symptoms. Can anyone confirm this?

It's a little too early to quantify wether it's had an affect on the fuel economy as I only fitted it last night. I plan to clean the panel filter this afternoon, and also aquire a full set of spark plugs, in the hope that this will improve the situation further. Was also contemplating a Squardra chip or re-map. Any suggestions on which option to persue.

Cheers

Dom
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Need a few more details...is it doing this when hot or cold or when just warming up?

Increased fuel consumption would lead to thermostat or water temp sensor.

wrinx
 

·
Registered
Joined
·
564 Posts
My fuel consumption had been increasing gradually for a few months and I noticed the other day that the car was running at around 70-75 degrees instead of 85-90 degrees, I've now changed the thermostat and the temp is back where it should be and I'll now have to check the fuel consumption when I fill up next :)
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Cheers Guys,
The car has been consistently flat, there seems to be no relationship between running cold or hot.

Cheers Chris I will check the lambda sensor fuse this afternoon. I guess I could disconnect the Airflow meter and see how it goes, tho I know it will run rough at idle.

Is the Airflow meter on the 1.8L 16V the same part as the 2.0L 16V.

There is what appears to be another sensor to the right of the Airflow meter, between the airflowmeter and the airbox. What is this sensor??

Cheers Dom

P.S Is anyone going to Oulton Park on Saturday?
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #7
daiblack said:
My fuel consumption had been increasing gradually for a few months and I noticed the other day that the car was running at around 70-75 degrees instead of 85-90 degrees, I've now changed the thermostat and the temp is back where it should be and I'll now have to check the fuel consumption when I fill up next :)
:eek: Is that the temp they are supposed to run at?? Mine generally only runs at about 60 degrees.....that is water temp isn't it?
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #8
the water temp should be about 90ºC. sounds like you need a new stat......
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Thanks for your replys,
Yesterday I changed the watertemp sensor from my 2.0 into the 1.8. I have a K&N panel filter in the 1.8, when I took it out it was pretty mucky, so I have put a standard one in until the weekend when I plan to get a K&N service kit. The power seems to be back now, I think the the dirty airfilter must have been having a significant affect on the airflow.

I also plan to do an oil and filter change, along with a set of spark plugs.

Does anyone have any suggestions on plugs, how bout NGK's?
Im ive seen the thread on oil types and so im not going to bring that topic up here. :rolleyes:

Dom
 

·
Registered
Joined
·
564 Posts
Alfa use NGK as standard but don't go to Alfa for them they'll rip you off!! either go to a motor factors that supplies NGK of get in touch with JackPJW at pjhotdog at hotmail.com (substitute @ for at) as he was able to get them at a very reasonable price ;) ;)
Also if you want to improve the airflow into the airbox there is a pipe Alfa do for the 145 cloverleaf that works (part number 60617628 at a cost of less than £2.50) but it does involve removing the large resonator from behind the bumper
:(
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #11
marlon said:
the water temp should be about 90ºC. sounds like you need a new stat......
Are you sure?.....90ºC is at 12 o'clock on the temp guage and thats when the fan cuts in when I'm stucjk in traffic....... :confused:

Is 90ºC not just for you clever fella's in yer smart V6's?? :p
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #12
mmm my 16 v runs at about 80 -85, the V6 is always at 90 tho
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #13
According to the manual, the thermostat opens at 83 degrees and the fan cuts in at 92 degrees....mine generally runs at between 50 and 80 ish....d'you think I need a new stat then??
 

·
Registered
Joined
·
564 Posts
The tecnician at the dealers told me to test it by "warm the car up to 90 degrees and then take it for a run, if the tempreture drops below 80 degrees the stat is fooked" that's how I tested mine and it was fooked.... ;) ;) ;)
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #15
My Silverstone runs just below 90ºC. I had to replace the stat when I bought it as it would barely register a temp.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #16
Thanks for your comments. After replacing the airfilter, water temp sensor, Airflow meter and lambda sensor. The car is going like sh*t of a shovel for want of a better term. I think that the old Airflow meter was goosed and the filthy K&N was having a huge impact.

I guess I could now work backwards to diagnose the faulty component/s, but seeing as it's going fine and the fuel consumption seems to be much better i'm not going to go there. I plan to change the oil and filter along with the plugs too, I hope this will improve matters further.

I may in the not too distant future fit a sqaudra chip, has anyone done so? How did the result compare to a standard car.

Regards

Dom
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #17
Squadra gives more torque right across the rev range. As you change gear the engine will pull straight away rather than having to wait for it to fill its lungs again. as you hit 7k revs the squadra just keeps going rather than loosing power like the standard car

You have to use super unleaded otherwise it will run crap at low revs
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #18
Hi Cream,
Is super unleaded higher than 95RON then? Stuff like optimax etc. It's the stuff thats usually about 7p more a litre could get expensive.

Dom
 

·
Registered
Joined
·
564 Posts
Dom if you want to chip the car and still use normal 95 RON unleaded, I would get an Autodelta chip like I put into my 2 litre. :) :) :D
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #20
yeah for the squadra you need optimax, super unleaded or BP ultimate, without 98 Ron the sqaudra is hopless
 
1 - 20 of 23 Posts
Top