Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi,

I have noticed a few weeks ago my engine makes a strange noise until it warms up. I have recorded a video yesterday and here is the link below, can anybody recognize what might be the reason? Can it be an early sign of a failing MA unit?

It seems like it is coming from the round gray cover which is side of the cylinder head and it sound like it is proportional to engine speed as I blipped the throttle.

Sound disappears after 15-20min normal driving (assuming that oil warms up, but even the coolant temperature rises around 60-70degC sound it still there).

Vehicle is 2,5yrs old and 61k KMs.

https://youtu.be/bdvyM6TDI-Q
 

·
Registered
Joined
·
153 Posts
I can't hear any squeaks, but I thought it was diesel, maybe it's my hearing, happy new year, hope you get it sorted
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Hello Iaria,

Thanks for the greeting, I wish you all a happy new year as well..

I admit that it is hard to notice on the video but there is a shimmy sound coming from there which seems more clear when I have moved the camera around (btw. 10-15sec) and very high frequency metallic noise when I have stepped on to gas.

Does any body know if there is any possibility of having a gear inside there with a broken teeth or something?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
You have given me a great hint, thanks. I have traced few DI gasoline engines and this shiny round cover seems like a cam follower and hosts the high pressure fuel pump. I will check it in the morning if it is the same as VW engines. Some TSI engines suffer from cam follower wear which might end up damaging the high pressure fuel pump itself or even the cam shaft.

I couldn't managed to find anybody from this forum suffered such thing before, does anybody hear anything about it?

Thanks again for the hint.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
I have checked the source of the noise again today, but it seems that round cover is a vacuum pump and I couldn't manage to find the high pressure fuel pump. As far as I have identified from the picture the manufacturer of the vacuum pump is Pierburg and reputation is pretty solid.

I also have recorded the noise from the interior. Can you think another source of such noise?

https://www.youtube.com/watch?v=vBggVtVB6uk
 

Attachments

·
Registered
Joined
·
49 Posts
I have checked the source of the noise again today, but it seems that round cover is a vacuum pump and I couldn't manage to find the high pressure fuel pump. As far as I have identified from the picture the manufacturer of the vacuum pump is Pierburg and reputation is pretty solid.

I also have recorded the noise from the interior. Can you think another source of such noise?

https://www.youtube.com/watch?v=vBggVtVB6uk
The Multiair Engines are port injected, not Direct Injection, and so there isn't any High Pressure fuel pump. This is indeed the vacuum pump but I think you might want to scan the vehicle for faults.
 
1 - 8 of 8 Posts
Top