Alfa Romeo Forum banner

working

  1. Fan blower not working

    Alfa Giulia
    Hi all. Fan blower decided to stop working today. Plugged multiecuscan and showing a electric fan control fault.( B1940-17 ) fault won't clear I also have a intermittent fault for the rear heated screen relay. Just wondering has anyone had this before and if it's a easy fix. Nearest dealer...
  2. Glove box light and Sun-visor Lights not working.

    Alfa 159, Brera & 946 Spider
    Hi all, Just bought my first Alfa :) really happy with it, got a 159 2008 with 55k miles on the clock it's a lusso 2.4jtd saloon. Just a quick question, ive looked everywhere and cant find an answer, my Glove box light and Sun-visor Lights don't work, ive tried with the engine on lights on...
  3. Interior compartment fan not working

    Alfa 147, 156 & GT
    Hi I'm new here just bought a 2000 156 selespeed 2.0L Twin Spark and my interior fan doesn't work It makes a strange noise in the driver's side footwell when I try and turn it on. I replaced the fuses for the climate control system and had a look at the fan unit under the glovebox (I think...
  4. Giulietta tail light om booth not working

    Alfa Giulietta
    Got a "check reverse light" om tre dash today. Turns out that the leds om tre booth cluster and revers is not working. How is this sorted? Sent fra min HTC U11 plus via Tapatalk
  5. seat belt light does not working

    Alfa 147, 156 & GT
    when starting the car the warning light of the fasten your seatbelt doesnt lit up, also there is no warning beep...... Anyone have a idea ?
  6. Boot light and boot open light not working

    Alfa GTV & 916 Spider
    My boot light and the boot open warning light on the dash aren't working. It seems to different to the problem most people have - my boot open light on the dash won't come on when the boot is open - most threads I've seen on here relate to the light being on when the boot is closed. I've done...
  7. iPhone audio over USB stopped working

    Alfa Giulietta
    Hey everyone my my iPhones have always worked over USB in my 2012 G with blue&me but in the last 2 weeks my iphone xs has stopped being recognised by the system (although it still charges). Does anyone else have this problem? What is the solution? Thanks.
  8. Radio/sat nav stopped working

    Alfa Giulietta
    Hi Folks, After two years trouble free fun with gqv I found that radio unit has stopped working. It still plays stuff and will connect with Bluetooth etc but display is dead and buttons don’t work. Have priced from alfa and can’t justify it for a 3 year old car. Anyone else had this happen? Any...
  9. Driver's side window stops working after battery drain - related or unlucky?

    Alfa 147, 156 & GT
    Hi! Recent owner of a 2007 Alfa GT 1.9 jdtm. Battery has been a pain and keeps draining - had a new one fitted and all is well. But after the first time it drained, the drivers side window has stopped working. If I turn the buzzer on in the menu I still get a beep from the switch, but no audible...
  10. Replacement stock 2din radio Head Unit not quite working

    Alfa 159, Brera & 946 Spider
    For the last 2 years I've been spending a couple of hours now and then trying to get the damn thing to work with the car. Original HU stopped working so I brought a direct replacement, sounds great radio, CD, steering controls all fine. Can I get audio from the car...no. USB, no sound. Connect...
  11. Heater not working

    Alfa Giulietta
    Hi hope someone can help got in car this morning and noticed dual control was illuminated now heater is stuck on cold and won't let me change it or turn it off
  12. Brera heater blower not working

    Alfa 159, Brera & 946 Spider
    Was fine yesterday, air con etc all worked until today. There is a click when trying to turn the heater on in any mode and just does nothing. Any ideas? Where is it located?
  13. Washer jets not working: electrical?!

    Alfa 159, Brera & 946 Spider
    So having some issues with my washer jets, they’ve stopped working (the wipers go when I pull the stalk) The tubes are not blocked. Tried replacing the pump the other month only for it to start working again (I put the new pump on, didn’t work, then the old pump back on which then worked). So...
  14. Boot and filler cap release not working

    Alfa GTV & 916 Spider
    Yep! Another thread! GTV 2001 phase2? I finally purchased this lovely car. Before bought the I was aware of these fault; Boot release, filler cap release and rear window heaters not working. Okay. Today I took my multimeter and got to work. I checked every single fuse (except those near...
  15. Battery not charging, battery light not working

    Alfa 147, 156 & GT
    Hello! My 156 JTS 2.0 is not charging properly and stalled mid-drive. I got help to charge it enough from another car to get it home. Voltage across the battery measures about 11.5V but slowly sinking. The battery light is not working, it does not light up when I start only the ignition or when...
  16. Still can't get blue and me working!

    ICE & Blue&Me
    Can't make any progress with this. Every time I connect it I get the English Language Unavailable message and the mileometer flashes. I've looked into it with MES and it doesn't register any fault codes from the blue and me module. I made a few changes and thought I'd cracked it but the problem...
  17. Menu Not Working

    Alfa Giulietta
    The menu, media player are not working and I can now longer connect my phone via Bluetooth, Any suggestions? I thought there was some sort of reset but if there is I can't find it. Thanks in advance! Sorry, should have added a few details. 2012 Giulietta 2.0 JTDM
  18. Stuff not working all of a sudden

    Alfa Giulietta
    Hello I have searched through page after page and cannot see a previous thread so here is my problem: Giulietta sportiva jdtm 170 2013 model I have lost Bluetooth, usb, ac only provides chilled air on LO (it hasjust been regassed and still only ice cold on LO) Cannot access steering...
  19. Electric Power Folding Mirrors Not Working?

    Alfa MiTo
    Hi Guys, My Mito's electric folding mirrors have never worked since I first bought the car used over a year ago. It's a 2011 170 Cloverleaf. It does have the button (Figure C in the manual) with a little mirror icon on it with a down arrow. Pushing it does absolutely nothing. Any ideas...
  20. Overheating/Heater not working

    Alfa Giulietta
    Hey Guys, I've searched around any while there are similar topics i'm looking for further ideas or some consensus on what this fault could be. Back in Jan the Giulietta 2.0JTDm heater suddenly stopped working and two minutes later the temp went to max and I had to ditch it on the side of the...
Top