Alfa Romeo Forum banner
washers
221-225 of 225 Results
Advanced
  1. Alfa 155
    Heylp! My front windscreen washers worked for about a day after I bought the Q4, I would now like them to work. :) the wipers activate when you hold the stalk down long enough, if the lights are on, the headlight washers drench the world (inc the screen if you are going fast enough!) but no...
  2. Alfa 155
    Having no joy with screen wash jets- drivers side (RHD) dribbles but no water at all on passenger side. I have tried the needle in the jets but nothing. Could it be a blockage elsewhere? The pump is making normal noises. Any solutions/suggestions most warmly received!
  3. Alfa 147, 156 & GT
    This might sound a bit silly but has anyone else had a problem with the windscreen washers. When I'm driving at motorway speeds the washer jets barely reach the windscreen, it's as if the pump is not strong enough.
  4. Alfa 145 & 146
    Hi Numan, Can you please tell me how I replace the non return valve for the headlamp washers (near side leaking out of the jets until bottle is empty). I take it its situated inside the bumper but I don't know how you take the 3 squirter jet system out I don't want to break it and can't work...
  5. Alfa 145 & 146
    A somewhat trivial problem by alfa standards but my headlight washers don't seem to be working and I'm trying to resolve if possible! Alfa check system light is on showing windscreen washer bottle empty, I've checked handbook which is as clear as mud on headlamp washers, and filled the washer...
221-225 of 225 Results
Top