Alfa Romeo Forum banner

turbo or boost

  1. 159 1,9 Jtdm Problems

    Alfa 159, Brera & 946 Spider
    Hello everyone, Im having some annoying problems with my AR 159 1,9 Jtdm. None of the workshops I've been to can help me, but hopefully this forum will. I've read some of the threads about this problem without really getting any proper answer, so im making my own. The problem is at gentle...
  2. Alfa Romeo Mito 1.4 T-jet LPG 155cv misfire

    Alfa MiTo
    Hi Guys, I bought an Alfa Romeo Mito 1.4 T-jet LPG 155cv. During the trial run I had some fault codes (P0300-P0304; P0240; P0037) on Petrol system on high RPM over 4000 I have started to review the system: - Check plugs - it looks good - Check coils - it looks good - Check turbo pressure - it...
  3. Boost gauge has a mind of it's own

    Alfa 159, Brera & 946 Spider
    I've had an unusual problem with my turbo gauge in my 2.4 Brera since I bought it 2 years ago. Most of the time it doesn't move at all, sometimes it will work correctly for the first 5 minutes of driving and sometimes it will be totally erratic, flicking from maximum to minimum regardless of...
  4. 156 2.4 JTD 150 turbo/boost issues

    Alfa 147, 156 & GT
    The turbo on my 156 JTD sometimes makes a loud whining/wooshing sound, which is accompanied by loss of power. The sound is intermittent, but usually there and always from a cold start, and loud enough to be heard at idle from inside the car. Split boost pipes was my first thought, but the...
Top