Alfa Romeo Forum banner
troubles
1-20 of 91 Results
  1. Alfa 159, Brera & Spider
    AO Member Join Date: Dec 2018 County: - Posts: 15 159 1.8 mpi troubles my 159 1.8 mpi gives malfunction. lambda after cat, no heating and no signal. have already replaced the lambda 2x but the fault keeps coming back. sometimes after 5 km but also sometimes after 500-1000 km. what is going...
  2. Alfa 147, 156 & GT
    my 159 1.8 mpi gives malfunction. lambda after cat, no heating and no signal. have already replaced the lambda 2x but the fault keeps coming back. sometimes after 5 km but also sometimes after 500-1000 km. what is going on? there is no false air, only the spark plugs have not yet been replaced...
  3. ICE & Blue&Me
    Hello everyone, I have 156 GTA that is fitted with BOSE from the factory of course. Before the car was mine, the previous owner had ripped out the amp and left a clump of wires hanging in the boot. When he was selling the car, it was asking for the radio code which he had assured me was in the...
  4. Alfa GTV & 916 Spider
    So, I recently bought a 2001 ts spider, it was an mot failure that had seen better days but has been well looked after in the recent past. the roof was inoperable when I viewed it but to be fair the clamshell motor was missing! I fitted a replacement motor today and gave it a try crossing...
  5. Alfa 147, 156 & GT
    Hi all, I would like to thank you for being accepted and would hope someone has had similar issues on just this code please? car - Alfa GT JTD Blackline (57) 2007 138k and seems had autolusso blue top hose and red bottom hose replaced. I have just purchased a new oil burner for company use...
  6. Alfa GTA
    I´m trying to register my car in spain and it has an Arqray japanese exhaust on it. To get it registered here I need to have EU approval numbers. The inspector is being quite helpful but his hands are tied! Does anyone here have a type approval number for an aftermarket exhaust? If so, could...
  7. Alfa 147, 156 & GT
    Bongiorno alfisti! Here is my list of troubles and I beg for an advice (e-m-m-m...advices :ponder: ), gentlemen. Alfa GT 2.0 JTS Selespeed. 1. Battery/Alternator. Circumstances: - 3 months ago in a service I was told that battery has <40% of its capacity left - since that I had a 80k...
  8. Alfa 147, 156 & GT
    Hi My old car has some issues. Any suggestions welcomed. Firstly, the ride has become worse lately. It feels like my front tyres are at 100 psi. The suspension absorbs large bumps OK, and is not seized, but I can feel every ripple in the road. Feels like the tyres are unbalanced but I...
  9. Introduce Yourself
    Hi there i m from belgium and the proud owner of a non running 1.8 916 GTV. I apperantly inherited the bug and at once a cluster of problems. The car is a non runner for about 8 years, and now its mine . The out side needs some professional TLC. I think you all can guess the reason I m on...
  10. Alfa 147, 156 & GT
    Hi, i have a big problem on my recently bought alfa gt 2.0 jts selespeed, it doesn't start engine. Major problem now is that the car is in first gear although displays shows N. I know because we tried to move the car pushing it, without results. So, not being the gear in N position doesn't let...
  11. Alfa Giulietta
    Hello All, Could anyone help with the following symptoms?... Every seat in my Giulietta 2.0JDTM is vibrating or undulating as if on a rough road (but not!). At low speed this is felt through the seat and body like an undulating bumpyness, as if the wheels are oval. At 60mph plus the frequency...
  12. Alfa 147, 156 & GT
    Hello. I bought few months ago a 147 1.9 JTD 16V pre-facelift and it came with ST Lowering springs kit. This model The car is lowered and handles very well, but on bumps it's just horrendous , a big pothole will make me jump off my seat. Even small ones I can feel very distinctively. Is this...
  13. Alfa GTV & 916 Spider
    Hi all, My Spider's hood is acting up. When opening the hood, it performs steps 3 and 5 simultaneously and generates an error. After solving this with the controls behind the seat, all is well although sometimes it stops before closing the cover completely. Also, the controls behind the seat...
  14. Alfa 147, 156 & GT
    Hi all :) Hoping someone could offer me some advice, my front left indicator has stopped working. I'm assuming the bulb has gone (well I hope its that anyway :P) My problem is I can't figure out how to get to the bulb as my indicators are round and different to the others I've seen. I can't...
  15. Alfa 147, 156 & GT
    Hello fellow Alfa Enthusiasts! First time poster, but have been reading, and following advice on the forum avidly for a while now. I am at my first Alfa, but as with many of you have fallen in love, it is hard to imagine driving anything else! On to business. So I have an 05 156 2.0 JTS...
  16. General Alfa Discussion
    Hi newbie here and 1st time alfa owner as always wanted a sportwagon.now own one and having had a nightmare time having gearbox and clutch replaced I'm now having trouble with the alarm.it has a 2 button alarm n the microswitch for the doors went.sent it away and had 2 new micro switches fitted...
  17. Alfa 147, 156 & GT
    So I decided to replace the auxiliary belt on my 156 (1999 2.0 Twinspark with AC), since the belt was very cracked and clearly slipping when I had a look. The new belt I put on is 1970mm long (the old one is 1975mm I think), but it squeals a lot on start up, but soon goes away. Now and then it...
  18. Alfa 147, 156 & GT
    Hello, lately I've been working on getting my old engine from my old car, into a new car. Both 156 pre-facelift. Everywhere I've looked, including a few posts here, recommend dropping the engines down rather then lifting them out. Which is what I thought I'd try. I've done an engine swap once...
  19. Alfa 164 & 166
    door lock on front passenger side stopped working, suspect burnt out motor. To cut a long story short I bought two replacement second hand motors that didn't work, so i assumed they were burnt out in a similar way to mine. Bought a third, which worked. Hooray! Now, two weeks later, it has...
  20. Alfa Giulietta
    I have had intermittent poor audio quality on my G since new in May. At first I thought it was less than perfect radio reception, the quality of my MP3 transfers or even my own hearing! However, I am pretty sure I have identified that it is one of the rear, driver's side speakers. If I use the...
1-20 of 91 Results
Top