Alfa Romeo Forum banner

tripmeter

  1. Trip meter gone, help!

    Alfa GTA
    I was driving just now, everything seems OK, it was a rainy day too. Stopped the car to pick up my wife. Started the car and the trip meter just gone. I don't use the trip meter that much but it's always a nice novelty. What could trigger the problem? I suspect a blown fuse or worse water seeped...
  2. Trip switch faulty

    Alfa 159, Brera & 946 Spider
    The trip switch on out 159SW has a mind of its own. Driving along the multi-function display will keep changing as if somebody is fiddling with the Trip A/Trip B switch. Every few minutes the beep goes off and Trip A Reset is displayed. The problem only starts once the cabin has warmed a...
  3. Tripmeter stays at 000.0

    Alfa 147, 156 & GT
    I was out thoroughly enjoying myself after having p6000s wrapped around each corner only to have my ride out spoiled by noticing my tripmeter stays at 000.0. When I press the trip/temp button it doesnt switch between the two, but as I drive along the mileometer still clocks up normally. If you...
  4. Tripmeter shows " ----- ---" on alfa 147

    Alfa 147, 156 & GT
    Hi, I have a problem with the tripmeter on my alfa 147, after i had problems with my battery and ran out of electricity, i changed the battery, and now the place were it shows the main km i made (i think it's called tripmeter) i see only "----- ---". Does anyone know what can i do to reset...
  5. tripmeter illumination and headlight adjustment motor

    Alfa 147, 156 & GT
    hi AO :) have two problems. car is 98 156 1.6ts, at turkey :p 1. the tripmeter (or whatever it is called; the digital display showing the total km, outside temp) 's illumination is gone. when i hold a torch to the display, i can see that the digital signs are still working, showing the...
  6. Tripmeter Problem

    Alfa 147, 156 & GT
    Previously on Alfisti temp forum. Anyhow, can any 147 owners confirm if they see a discrepency in measuring distance between the tripmeter (which is zero'ed by the "km" button), and the "TRIPMETER A" which can be seen on the middle display panel? I am seeing quite a discrepency (approx 2km...
Top