Alfa Romeo Forum banner

starts

  1. 1.6jtdm starts but then cuts out

    Alfa Giulietta
    Hi My wife’s 1.6jtdm developed a strange fault, cars been absolutely fine but today she went out to start it after it had been sat for few hours, it started but really lumpy and cuts straight out after a few seconds.. won’t go any further than that point, won’t even rev, accelarator has no...
  2. Starts up then revs gradually drop until the engine stalls

    Alfa Giulietta
    Hi all! I've noticed a bit of a weird problem with my 2015 Giulietta Sprint (16.5k miles) - a couple of times now, upon starting the engine, the revs just won't remain stable and they will drop down after the car has started until it stalls. The first time this happened at the end of the day...
  3. Anyone had this case? 147 jtd starts AC compressor by itself!

    Alfa 147, 156 & GT
    As the title states..Once in every 10 cold startups, the AC clutch can be heard cycling on and off several times, even though the Climate control unit has been off...after few seconds it will stop doing this or if you start AC by pressing the controls of the climate control unit . The car is...
  4. Cold morning starts!

    Alfa Giulietta
    Morning guys, just wandering if anybody else has experienced any issues this morning with their car. Mines a 2.0 tct diesel and cut out on me on a roundabout. I’m thinking it’s the cold temperatures and an old battery. After five minutes it restarted and I was away but now have a check engine...
  5. Starts OK, idles roughly, will not rev

    Alfa 159, Brera & 946 Spider
    09 159 2.4 JTD m,TI, automatic, 135 k km, Starts OK, will not rev, happened suddenly. Only fault codes showing up are P1723 and P1724, which are transmission codes? But goes into drive OK and reverse OK but not enough revs to go anywhere!!! No EML, could be ERG? Help please, thanks
  6. If your Giulia stereo suddenly starts sounding like its drowning in water...

    Alfa Giulia
    This morning when I turned on the radio it suddenly sounded really bad, no bass, limited range of sound etc (it is the HK one). Tried different channels and Spotify, no joy. Turned the unit and car on/off, reset audio settings, no joy. Finally I manually disabled surround sound in the menu and...
  7. Giulietta QV TcT starts then dies.

    Alfa Giulietta
    :smokin: Good day Giulietta enthusiasts. A couple of points to get out of the way before you point to them Batery has been replaced 2 weeks ago The car had a pedal box fitted which I removed soon after experiencing this issue The car has a Unichip fitted I have checked the sensor on the...
  8. Whirring TBi on cold starts

    Alfa 159, Brera & 946 Spider
    The recent cold weather shed some light on existing problems with my 159 TBi: the base problem was that everytime when starting from cold, I got a whirring "diesel" sound from the engine, at least for the first 2 presses of the accelerator. After these first two quick revvings (pumping the...
  9. 159 2.0 JTD engine starts, idles but won't rev ?

    Alfa 159, Brera & 946 Spider
    Any ideas anyone for this one please This is very intermittent- maybe once a week usually from cold Once I switch off and restart it's ok and revs / accelerates as normal I'm thinking maybe a fuel pressure issue ?
  10. 159 2.4 jtdm starts then immediately cuts out

    Alfa 159, Brera & 946 Spider
    Hi I recently purchased my 159 and i have to say i love it. However today the wife decided we needed to go shopping so into the car we get, it starts up normally, we drive 100 yards down the road and the car stalls. I try to restart it and it will fire revs to 750rpm then instantly cuts out. It...
  11. 2.0ts starts but will not rev, very lumpy idle

    Alfa GTV & 916 Spider
    Hi guys New to this forum but need you help. I have just spent the last few months rebuilding engine from my 1999 Spider 916 2.0ts. It needed bottom end rebuild (new shells etc). Before it got noisy was running well. Now fully reassemble and back in car. Starts on the button but will not rev at...
  12. 14th March - Giulia starts production

    General Alfa Discussion
    Yes, finally a date.. Sergio was visiting Cassino yesterday and he confirmed a start date for production... Alfa Romeo - Marchionne A Cassino: La Giulia In Produzione Dal 14 Marzo - Quattroruote
  13. 156 selespeed starts but selespeed light flashing

    Alfa 147, 156 & GT
    Hi everyone. I'm a newbie here but on my 3rd alfa 156 selespeed - seven and a half years of fun without problems! First I had a 2001 sportwagon TS 155, then a 2002 sportwagon TS 150 and now I'm driving a 65,000 mile 2003 JTS selespeed saloon and have had it 3 months with no problems until this...
  14. Stop starts,,, stopped stop starting

    Alfa Giulietta
    2014 2.0jtdm-2 150bhp The stop start has worked fine for over the year of ownership but the last 2 months the stop start has been getting less and less now it never cuts in? I recently did 2000 miles in 1 week long distance and it never once cut in (battery would be full) im getting no...
  15. 147 JTD 1.9L Turismo 8V Engine starts then stalls immediatly

    Alfa 147, 156 & GT
    My wife took my car out for the first time today got 400 metres down the road when she stopped to turn right the engine stalled. She immediately started it again but it would not rev. above idle speed then after a few seconds the engine stalled. ( The engine is still cold / not working...
  16. spider starts rough, idles rough, then stalls

    The Classic Alfa Romeos
    Hello Guys i need your help. My car is starting to start rough, idle rough then stalls out. I have put a video below. Let me know your ideas thanks Watch "86 Alfa Romeo rough start, rough idle, then stalls" on YouTube https://youtu.be/oOp5ih2keVA Thanks
  17. 2.4 20v starts for 5 seconds then dies

    Alfa 147, 156 & GT
    Hi, 2006 20v 156 The Short..... The car will only fire briefly reaching a max of 700rpm then dies. The low pressure pump is giving good pressure and ive put a new fuel filter in. There are no error codes either. The Long.... Bought in as a non runner, aparently it just died and never restarted...
  18. Only 20 Hours till Top Gear Starts

    General Motoring Discussion
    :)
  19. 156 1.8 TS - lean idle, bad cold starts

    Alfa 147, 156 & GT
    SOLVED: 156 1.8 TS - lean idle, bad cold starts Hi all, I have strange issue with my 2000 156 1.8 Twinspark. When starting cold engine, revs will drop very low after few seconds, engine almost stalls. If I touch accelerator for a moment and then release it, it settles down and seems fine. But...
  20. A few False Starts To Alfa Ownership

    Introduce Yourself
    Back around 2005 I was just about to place and an order for a 159 Lusso saloon as a company car when my employer stopped the scheme, Id even chosen the colour. A couple of years later I almost bought a new Ti but at the last minute got cold feet and bought a BMW330d couple instead. Over the last...
Top