Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 500 Results
  1. Alfa 159, Brera & Spider
    Hi everyone, I am trying to resolve this problem for almost a year, already replaced many parts and still no luck :( My car is Alfa 159 1.9jtdm, Qtronic 110kw. Issue happens during the first start after car is parked overnight. I open the car, sit inside and start the car: Little longer...
  2. Alfa 159, Brera & Spider
    I have a bit of a rough start with a slight screech on startup, cold or hot. Is this something I should be concered about? It is quite irritating. here’s the sound; Alpha 159 1.9jtdm Sqeaky start. Any advice would be appreciated. 1.9jtdm 159
  3. Alfa MiTo
    I recently acquired a Mito Cloverleaf with a Stop \ Start problem that seems to be related to the starter motor circuit and was wondering if anyone has a wiring diagram so I can trace the fault? I have searched for one with no success. The symptoms are as follows: The car drives fine, when you...
  4. Alfa MiTo
    Hey! I’ve had my 11 plate Mito for about 2 years now and well, let’s just say it’s not been the cheapest thing to keep going :confused: Anyway, after I’d filled it up with petrol, I set off and after a few minutes I noticed the two airbag warning lights had lit up along with an exclamation...
  5. Alfa Romeo 147

    Still a lot of work to do, sideskirts, front and rear bumpers, etc etc.
  6. Alfa MiTo
    Hello everyone, I'm a new Alfa owner and new to the forum. I recently bought an Alfa Romeo Mito 1.6 Jtdm 85 kW. Car had slight issues while starting since I bought it but nothing too worrying (about 2 seconds of crank and it would fire up and work perfectly). In the winter as temperatures...
  7. Alfa 147, 156 & GT
    Charged battery and still nothing. Battery is o.k. it almost started then lights where mileage is went out. All other lights and fuses o.k
  8. Alfa 147, 156 & GT
    So I decided to try and ask here, as me with my mechanic are out of clues on this one. The problem actually shown itself last winter, but not as pronounced as this year. With the temps going down overnight, first cold start after the car sat in the cold, this horrible squeaking happens. It is...
  9. Alfa Giulia
    Hello site members. My first post (other than intro). I picked up my new Giulia on Saturday and since then I have been finding any excuse to take it out. Absolutely fantastic car. Is there any way to stop the radio/media playing on startup without the infotainment system being completely...
  10. Alfa 159, Brera & Spider
    So I'm working on a 2010 Vauxhall Insignia 2.0 CDTi, I know it's not an Alfa but I'm on this forum anyway and it's pretty much the same engine as the 2.0 JTDM, so I hope you don't mind me asking here. The VX forums are very quiet unfortunately. I bought the car for a £500 with a snapped...
  11. Alfa 147, 156 & GT
    Hello! I am currently fixing this Alfa Romeo 156 JTD. The car has had a fuel filter, heating plugs, crankshaft/rpm sensor and timing belt replacement. The owner complained that the car when cold was hard to start and when hot the car wouldn't start at all. The engine cranks fine, so I'm not...
  12. Alfa 147, 156 & GT
    Hi, This is my first post on this amazing site although I have used it many times to assist me with the tiresome ownership of an Alfa Romeo. GT in my case, 2004 JTS. I originally bought a bit of a dog although the service history did stack up. 75,000 miles OTC, backed up too. I have done and...
  13. Alfa 159, Brera & Spider
    On cold sart engine will missfire, fart and one one occassion emit a foul smelling smoke/vapour that smelt like burning kerosene/paint. I live in an area where temp's can vary from zero to fourty degrees and the alfa has handled this for years with no issues. Car is 13 years old and done 176,000...
  14. Alfa 159, Brera & Spider
    Cold start problem 159/Brera Dear All, I have an Alfa Brera 2006 model With 2,2 JTS petrol engine. When I shall start the car after more than 6-8 hours ( or overnight) in the morning I very often have to push the starter button twice. On the second push the cars always start and runs perfectly...
  15. Alfa MiTo
    Hi all, I have a weird one here maybe someone has some suggestions that may help. OK I have bought a Mito 1.3 JTDM 2010 (59 plate) for my sons first car, perfect in every way and he loves it except one little issue. When starting it randomly does not start, the engine cranks but it does not...
  16. Alfa 147, 156 & GT
    Hi all, With the hot summer and pollen level at bonkers I decided to finally get my AirCon recharged. I’m normally ok with just the window open but thought after a couple of years with no cold AirCon I’ll get it done. I got it done and it held the cold air for a while. Anyway that lasted not...
  17. Alfa 164 & 166
    ok, 1995 164 3.0 24v, turns over but not starting, not even trying. tested the red stripe relay and the fuel pump relay next to it, and they are ok. any where else I should be checking? fuses relays etc thanks in advance
  18. Alfa Giulia
    Has anyone done this? Think some tuners can remove the function of pumping heat into Cat upon startup until warm. Have an aftermarket exhaust and happy with sound except on cold start when it sounds too much. Have you heard of any alfa tuners who have done this on Giulia or other models? Is...
  19. Alfa 147, 156 & GT
    Hi everyone, I've 'lost' my original account here, it's been a long time but I've been drawn back into the Alfa fold after a few years without. I've purchased a 147 Jtdm but now it's arrived, it seems to have a problem that I wasn't aware of... From dead cold, it'll crank, fire, idle for...
  20. Alfa 159, Brera & Spider
    When I start the engine it's never smooth, it's as if the engine is loose (it isn't). It starts up straight away no prolonged turn over it just comes in with a thump, not smooth at all. The only time it seems to be OK is when it's hot from running and the external temp is also high. I've just...
1-20 of 500 Results
Top