Alfa Romeo Forum banner

stalling

  1. Alfa 75, RZ, SZ
    Hi, Running a 75 TS engine in a spider. It runs really well until you go over a bump then feels like it is going to cut out and 'kangaroos' all over the place. it always has done it since its had the engine from the 90's. The in tank pump is running as is the main fuel pump, new dizzy caps...
  2. Alfa 147, 156 & GT
    Hi, About a week ago while driving home from work I pulled up at a set of traffic lights, dipped the clutch to take the car out of gear and the engine died. The dash showed an immobiliser fault warning and a key symbol. I tried restarting the car but it wouldn't fire I guess due to the...
  3. Alfa 147, 156 & GT
    hi there, newbie to this site so please be gentle. can any one help with my car stalling when I come to a stop. it doesn't happen every time I stop it seems to only happen after 10 mins then it comes and goes. Its not a schoolboy error of not having the clutch in. I noticed it yesterday...
  4. Alfa 147, 156 & GT
    My 2.4 10v is stalling/cutting out while driving, but as soon as dip the throttle, its fine. Does that at 2.5k+ FES - no codes. Feels like some sort of over boost failsafe. Would a faulty crank sensor trow up a code? Any ideas? cheers
  5. Alfa 147, 156 & GT
    2005 156 2.0 JTS Just had some work done on the bottom end, new shells, since then when I start it up in the morning I have to hold the accelerator down at just under 2000rpm to stop the idle speed dropping to below 800rpm and stalling. Have to do this for about 2 minutes then all is fine. There...
  6. Alfa 159, Brera & Spider
    Hi all. I have a very odd fault with my qtronic. In drive or a gear there is no torque slipping or engagement of neutral. This causes the engine to stall when stationary and makes pulling away difficult (I must create high revs then move lever from n to d). If I select n using the selector the...
  7. Alfa Giulietta
    Hi, I don't think that the 2 are related but, I though I better check. When I got home tonight, my wife told me that while driving down a hill today the car slowed down all of the sudden as if someone pulled the handbrake half way, once she tried to accelerate nothing happened and it felt like...
  8. Alfa 147, 156 & GT
    Hi all, For over a week now I've had issues with my 147 Q2 when setting off from a junction or the carport. The best way I can describe it is to say that it feels as though I'm setting off in 3rd gear. I let the clutch bite and the car moves forward very slowly before juddering and I have to...
  9. Alfa MiTo
    Hi, I have a new 13 plate Mito 1.3JTD-85 BHP the car runs fine but I have noticed a strange problem, when the engine is cold and I first turn it on the engine stalls. I have tried applying some throttle but it makes no difference, it is almost like the STOP/START kicks in (yes I have my foot on...
  10. Alfa 147, 156 & GT
    Hello, I have a recurrent symptom with my 156 2.5V6 (AR32405). I describe some cases, perhaps somebody can say some good advice. ========== 2013-03-26 ========== I've replaced the complete MAF (sensor+housing) to original Bosch one. This replacement was recommended by a diagnostic service and...
  11. Alfa 147, 156 & GT
    Hi guys, My V6 isn't idling right, stuttering between 500 to 1000 rpm when at a standstill or in neutral. It also often stalls when it is being parked, as I change into reverse gear. (much to the mirth of onlookers!) Just been looking back through the history and I can see she has had: -...
  12. Introduce Yourself
    Hi All Im new to this site, so looking for some help or advice please. My Brera suddenly died on me the other day. Would not go but started. Took to my local mechanic who changed Oil Filter, Glow Plugs, Air Filter, Fuel Filter and put new oil in. - However, there now seems to be no power...
  13. Alfa 147, 156 & GT
    Hi guys, Currently having an issue with my 2005 156 1.9 16v JTD M-J. Car starts up absolutely fine, idles rough (especially first thing in the morning). I can bring it up to biting point and it moves happily enough using the clutch alone. Touch the accelerator at it cuts out straight away...
  14. Alfa 147, 156 & GT
    My 156 had to race a train the other day, pedal to floor for about 2 hours. Since getting home the car is struggling 0-2000 RPM, and stalling in 1st when the accelerator is touched (biting point and using clutch only it's fine). After 2 stalls, the car goes as normal, though sluggish under 2000...
  15. General Motoring Discussion
    Hi, just after any helpful hints you clever bunch might have. My son has a Corsa, 1.2, he's a learner and has his test later this month. So I've been taking him out in the Corsa for extra practise as well as the lessons he has. Anyway, the corsa has suddenly started behaving strangely. It...
  16. Alfa 147, 156 & GT
    I've got an Alfa Romeo 156 ts. 1999. What happens is when I'm driving for about 20 Mins or so. The engine warning light would come On and at the same time my car would Slow down. Once this starts to happen when I try to accelerate Nothing would happen. So basically I have to come to A full...
  17. Alfa 147, 156 & GT
    Over the last couple of days I have experienced the sensation of stalling when slowing down from around 80mph to around 70pmh in 6th Gear. I drop to 5th immediately problem solved. Still getting used to having the 6th gear ...is 70mph too slow for 6th? , that's exactly what it feels...
  18. Alfa MiTo
    Any other owners seen this?... For the last week or so, my 1.4 turbo has been starting then stalling immediately after it fires (like a quarter of a second later). Second crank stays running. Car is only 23000km old, regularly serviced, battery sounds OK. Weather has been cool in Sydney...
  19. Alfa 147, 156 & GT
    Hi guys, I have recently acquired a 156 2.5 V6. Car is pretty old as she is on a 98 plate, but has lots of history and only 68k on the clock. She has not been idling right since I bought her and sometimes when at traffic lights the revs stutter more and more and she stalls. Also sometimes...
  20. Alfa 147, 156 & GT
    Hi all, My 156 has developed a poor idle. When left to idle and can cut out or hunts. otherwise the performance is perfect. any ideas? My instincts are suggesting a gummed up throttle body or idle speed control valve fault (does it have a separate air circuit around the butterfly controlled...
Top