Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Alfa Giulia
    Experiencing sporadic passive entry operation on drivers door handle - car was very dirty, so thought it may have been down to this, but still occurs after a good wash. Dealer visit due early jan so will raise with them, but just wondering if anyone else has had problems?
  2. Alfa MiTo
    Hi guys, I have 2010 1.4 turbo Mito with 120k on the clock. It has happened twice now that the car did not want to start. It swings but refuses to start. As soon as that happens I get the amber warning triangle with exclamation mark lit up. Thereafter the computer gives a few messages like "fuel...
  3. Alfa 147, 156 & GT
    Having a really weird issue with my 156 at the moment; Every now and then i come across a puddle of coolent under the rad, and when i check the level has either not perceptibly changed, or dropped a little (i topped up with maybe 200ml this morning.) But it may be weeks before the little puddle...
  4. Alfa 159, Brera & Spider
    After driving a friends Brera, I decided to bite the bullet and buy a Brera of my own. I came across a 3.2 automatic in excellent condition and virtually brand new. It's a 2007 model and has only 5000miles on the dash. Needless to say, I love it. Problem is now though that every now and again...
  5. Alfa 147, 156 & GT
    Dear all, sometimes it happens, after a while of driving, that my AR156 1.8 TS will not start again. Just a click is heard, but it does not start the engine, even not cranking. After 5-10 mins of waiting, it starts normaly again. This happens once per 20 startings. What's wrong? Thanks.
1-5 of 5 Results
Top