Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-19 of 23 Results
  1. Alfa 147, 156 & GT
    Just bought this car dead Selespeed. Put in a "New actuator" second hand unit , supposedly worked. Selects 1 and 2 and shows R but R goes in forward gear? 1 seems like it is correct but 2 is too fast 80kph @3,000rpm which is not 2 but 4 probably. *No city mode? I think the paddles are...
  2. Alfa GTV & 916 Spider
    Dear Alfa Hive mind - My first post as a new owner of a very tired Ph1 20TS spider. So please be gentle! The temp gauge reads a very steady 70 instead of 90. I've done a lot to the car so it's becoming a mystery.... I have had a service (new filters, plugs, water pump, belts etc. etc.) done by...
  3. South West
    Hi, Just wanted to know if there's any car shows going on in Bristol? Sent from my iPhone using Tapatalk
  4. Alfa 159, Brera & Spider
    Hi. I have 2 quick questions (these might be very obvious / noob questions). So last time on the highway the "check engine light" came on when I accelerated hard from the intersection. More specifically, I floored the car in 3rd gear and at the exact moment when I switched to 4th gear the engine...
  5. East Anglia
    Hey all just find out if there is any car meetso or shows coming up in the near future ?
  6. Alfa 147, 156 & GT
    147 JTD, car won't start up and "Immobilizer" shows up when lights are left on For example, if my car stalls, which happens a lot lately because of the clutch, I guess. The car vibrates quite a bit on startup and stalls if I don't give it enough gas, quite more than I'm used to, but that's not...
  7. Alfa 147, 156 & GT
    Hi to All, I am looking for help to solve following problem with my 2005 Alfa Romeo 156 JTS Selespeed. I was driving my car for wheel alignment to a local Bridgestone service centre but missed a turn by a bit. It was not a busy road so I decided to reverse and drive backwards, but gear would...
  8. General Alfa Discussion
    Probably been posted before , but anyways ..........Classic Motor Shows in the UK | Veteran Motor Shows | Heritage Motor Shows UK
  9. Alfa 147, 156 & GT
    Hello fellow enthusiasts & sufferers, I have a problem with my 2007 GT jtd in that the fuel gauge shows empty, display shows 0 range and she will not start. There is plenty of fuel but I have added extra diesel to be sure. She turns over but symptoms are that of being out of fuel. When I switch...
  10. East Anglia
    Being a proud owner of a ph2 Spyder, I'd like to get it all detailed and show it's sleek pininfarina lines off at some classic shows. Have we, as an area, got any shows penciled in around the country at all that we can convoy to?
  11. Alfa 145 & 146
    Hello, it's me again with a question/problem: I have an Alfa 145 1.4 boxer and currently the dimensions of my wheels and tires are 195/50/15. That's about 1.5% larger in diameter than the factory 175/65/14 but as it stands, my speedo is telling me I'm driving about 18-20 km/h more than the...
  12. South East
    Hi All. Bit late I know but is anyone going to Capel on Sat or Cranleigh on Sun. Both are darn good.:thumbs:
  13. North West
    Can't decide Tatton Hall or Stanford Hall:confused:
  14. Northern Ireland
    Guys, please keep an eye on the sticky threads as I will be posting details of any runs or shows organised either through AO or the NIIMC. At present NIIMC have arranged to attend a show on the 4th June which I've stickied above and it is hoped to have our own All Ireland Italian Car Day on the...
  15. Alfa 33, Sud & Sprint
    heres a couple of shows coming up, is anyone looking for a northern show to go to? im thinking of having a ride over to the yorkshire one in harrogate :thumbs: and the later one at raby castle is about 3 miles from me :) and the one in ripon on the 5th of sept isn't to be missed!!!! Markwood...
  16. Alfa 147, 156 & GT
    hi i just got hold of a 156 2.0 selespeed. it runs fine but wont rev up and there is an injection warning light on the dash. as i have n clue about electrics or alfas really so i thought i would see if you knowledgeable lot knew what the prob might be. all thoughts wellcome and thanks for...
  17. Alfa 147, 156 & GT
    Hi, I have a problem with the tripmeter on my alfa 147, after i had problems with my battery and ran out of electricity, i changed the battery, and now the place were it shows the main km i made (i think it's called tripmeter) i see only "----- ---". Does anyone know what can i do to reset...
  18. North East
    Is it me or is the North East poor for car shows? We have excellent facilities in the area that could be used. It would be good to see a prestigeous show in the North East including cars from the likes of Italy and Germany and other countries. You see many nice cars on the roads which could be...
  19. Alfa GTA
    Hi, The Oil Temperature Guage in the Onboard Computer display changes to dashes once the engine is up to temperature. Anybody know why this would be? Is there a temperature sensor for the oil that should be replaced? Cheers Sean
1-19 of 23 Results
Top