Alfa Romeo Forum banner
rough
301-315 of 315 Results
Advanced
  1. Alfa 145 & 146
    Hi, I've recently bought a 1999 146 1.4 TS 16v Sport with 49000 kms, instead of the 1995 155 2.0 TS 16v Sport :( I had to let it go... it was nothing but trouble... This little 1.4 drives like a charm for a 1.4... (completly underpowered after I drive the 33 16v ;) :D) ) but it's less likely to...
  2. Alfa 147, 156 & GT
    The brothers 156 1.8 TS is having a problem. Sometimes on idling, the engine goes really rough and the revs drop, and pressing on the accelarator doesnt do anything. Then it will be fine. Sounds like it could be a sensor? :confused: Any ideas?
  3. Alfa 147, 156 & GT
    Can anyone help, Intermtantly my car lose's its performance and refuses to rev freely (as if someone has blocked the inlet) at the same time the temp gauge rise's to 90+ the car seems to be at its best when cold for the first mile. Also does anyone know of a workshop manual? or where i can...
  4. Alfa 147, 156 & GT
    This is a reply for Ross who sent me a pm. I cant send you an email as i don't have your address and you are not receiving pm's. Anyway the rough running on my 2.0TS was caused by water collecting in the spark plug wells. Dealer cleaned out the water and took out plugs/leads and gave them a...
  5. Alfa GTV & 916 Spider
    Hi, My 1999 2.0 litre Twin Spark has started to sound a bit rough. She has covered 68,000 miles and been serviced regularly. I had the variator done at 64k miles, also had the timing belt done at the same time. There is a distinct ticking noise (tappets?) coming from the back/top of the...
  6. Alfa 155
    Hi all, My 2.0 litre 8valve has the follwing problems: High co levels (only just scraped through an MOT pass) Hesitation/misfire at low revs under load Fluctuating RPM (only noticable above idle at steady throttle opening) Any ideas?
  7. Alfa GTV & 916 Spider
    Hi all, I was wondering if anyone could help diagnose a running prob with my GTV? Its a little hard to explain, but basically sometimes when you come off the throttle and are cruising a low speeds the ride is very 'jerky'.. This happens when cold or hot, and even if you go to a lower gear it...
  8. General Alfa Discussion
    I need some help. I have a 1991 spider veloce that runs perfectly with the exception of a "stumble" when idling about 50% of the time. I replaced the fuel filter just in case it had some random junk inhibiting the fuel flow at low RPM but it had no effect. It accelerates flawlessly and only...
  9. Alfa 145 & 146
    Can anyone shed some light on this. My 145 Cloverleaf has developed an irritating rough idle. I had the car serviced by Alfa Romeo and they diagnosed the rough idle as a faulty Lamda sensor. Rather than get them to repair it I thought I would get the work done elsewhere, however they said...
  10. Alfa 155
    Ive just read some old messages about fuel economy and how most of you are getting around 300 mile or so out of a full tank of petrol, however i am only getting around 260 or less if i give it beans. The engine seems to run ok when warm althought the power curve doesn't seem quite as smooth as...
  11. Alfa 145 & 146
    I have just had a new clutch fitted by my local Alfa romea specialist. The clutch came from Alfashop and the garage didn`t mind that i supplied it. I thank them as they did it at very short notice (3 days). The old clutch was totally lunched. It now drives fine but a slight misfire on tick over...
  12. Alfa 147, 156 & GT
    I dont know how many of you have a 1.6 but i'd like to know whether i'm the only one who thinks the 1.6 sounds crap when it's idling???? Mine kinda sounds like..hmm.. a quiet diesel!! When you get going it's a different story, its just when your stopped. Is it the same with the 2.0??? Does...
  13. Alfa 155
    When I drive a righthand radius I hear a rough noise from the left front wheel. Not loud but also not a good sound. My mechanics have looking for twice times but they haven't found a damage. What could it be ??? When I drive a lefthand radius or straight on there is no sound. And there is also...
  14. Alfa 155
    Hello..! I´want to know that,does anyone have the same engine noises than i have....when engine is cold it runs smoothly but when the oil(10-40w)is hot engine starts to make roughin noises.Valve clearances are ok and camshafts too and the "cups" under cams..! Engine is 2.0 t.s 8V 135tkm on the...
  15. Alfa 155
    Wondering if any of you have ever faced this sort of problem before. I've seen some cases of erratic idling (in other posts) but mine occurs only when car is in the move. Alfa 155 1.8 16V Rough idling when car is on the move. When car is moving with engine running and the transmission is in the...
301-315 of 315 Results
Top